CVE-2026-25517 Wagtail has improper permission handling on admin preview endpoints
An authenticated admin user can bypass permission checks to view sensitive database contents via crafted preview submissions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25517?
CVE-2026-25517 is a medium-severity missing authorization vulnerability in wagtail, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Wagtail is an open source content management system built on Django. Prior to versions 6.3.6, 7.0.4, 7.1.3, 7.2.2, and 7.3, due to a missing permission check on the preview endpoints, a user with access to the Wagtail admin and knowledge of a model's fields can craft a form submission to obtain a preview rendering of any page, snippet or site setting object for which previews are enabled, consisting of any data of the user's choosing. The existing data of the object itself is not exposed, but depending on the nature of the template being rendered, this may expose other database contents that would otherwise only be accessible to users with edit access over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.6, 7.0.4, 7.1.3, 7.2.2, and 7.3.
Weakness: CWE-862
Which versions are affected by CVE-2026-25517?
11 open source packages ship an affected version, including wagtail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | All versions | 6.3.6, 7.0.4, 7.1.3, 7.2.2, 7.3 |
wagtail PyPI | All versions | 6.3.6 |
wagtail PyPI | All versions | 6.3.6 |
wagtail PyPI | From 6.4rc1 | 7.0.4 |
wagtail PyPI | From 6.4rc1 | 7.0.4 |
wagtail PyPI | From 7.1rc1 | 7.1.3 |
5 more packages
wagtail PyPI | From 7.1rc1 | 7.1.3 |
wagtail PyPI | From 7.2rc1 | 7.2.2 |
wagtail PyPI | From 7.2rc1 | 7.2.2 |
wagtail PyPI | From 7.3rc1 | 7.3 |
wagtail PyPI | From 7.3rc1 | 7.3 |
Products include Torchbox Wagtail.
How do I fix CVE-2026-25517?
Upgrade wagtail to a fixed version for your release line: 6.3.6, 7.0.4, 7.1.3 or 7.2.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-25517 being exploited?
There is no known exploitation of CVE-2026-25517 in the wild and no public exploit code.
Other vulnerabilities in wagtail
- CVE-2026-54263 Wagtail: Reflected XSS in dynamic image URL generator view
- CVE-2026-54261 Wagtail: Improper permission handling in image preview
- CVE-2026-44197 Wagtail: Improper permission handling when comparing revisions
- CVE-2026-44199 Wagtail: Improper permission handling when deleting form submissions
- CVE-2026-44200 Wagtail: Improper permission handling when copying pages
Sources
Also known as GHSA-4qvv-g3vr-m348, PYSEC-2026-2030.