# CVE-2026-25517: Wagtail has improper permission handling on admin preview endpoints

> An authenticated admin user can bypass permission checks to view sensitive database contents via crafted preview submissions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-4qvv-g3vr-m348, PYSEC-2026-2030

## What is CVE-2026-25517?

CVE-2026-25517 is a medium-severity missing authorization vulnerability in wagtail, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Wagtail is an open source content management system built on Django. Prior to versions 6.3.6, 7.0.4, 7.1.3, 7.2.2, and 7.3, due to a missing permission check on the preview endpoints, a user with access to the Wagtail admin and knowledge of a model's fields can craft a form submission to obtain a preview rendering of any page, snippet or site setting object for which previews are enabled, consisting of any data of the user's choosing. The existing data of the object itself is not exposed, but depending on the nature of the template being rendered, this may expose other database contents that would otherwise only be accessible to users with edit access over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.6, 7.0.4, 7.1.3, 7.2.2, and 7.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-25517?

11 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | All versions | 6.3.6, 7.0.4, 7.1.3, 7.2.2, 7.3 |
| `wagtail` | PyPI | All versions | 6.3.6 |
| `wagtail` | PyPI | All versions | 6.3.6 |
| `wagtail` | PyPI | From 6.4rc1 | 7.0.4 |
| `wagtail` | PyPI | From 6.4rc1 | 7.0.4 |
| `wagtail` | PyPI | From 7.1rc1 | 7.1.3 |
| `wagtail` | PyPI | From 7.1rc1 | 7.1.3 |
| `wagtail` | PyPI | From 7.2rc1 | 7.2.2 |
| `wagtail` | PyPI | From 7.2rc1 | 7.2.2 |
| `wagtail` | PyPI | From 7.3rc1 | 7.3 |
| `wagtail` | PyPI | From 7.3rc1 | 7.3 |

Products: Torchbox Wagtail.

## How do I fix CVE-2026-25517?

Upgrade wagtail to a fixed version for your release line: 6.3.6, 7.0.4, 7.1.3 or 7.2.2.

## Is CVE-2026-25517 being exploited?

There is no known exploitation of CVE-2026-25517 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25517 and fix it if it is affected.

What it is: CVE-2026-25517 is a medium-severity missing authorization vulnerability in wagtail, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25517 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected all versions; fixed in 6.3.6, 7.0.4, 7.1.3, 7.2.2, 7.3
- wagtail (PyPI): affected all versions; fixed in 6.3.6
- wagtail (PyPI): affected all versions; fixed in 6.3.6
- wagtail (PyPI): affected from 6.4rc1; fixed in 7.0.4
- wagtail (PyPI): affected from 6.4rc1; fixed in 7.0.4
- wagtail (PyPI): affected from 7.1rc1; fixed in 7.1.3
- wagtail (PyPI): affected from 7.1rc1; fixed in 7.1.3
- wagtail (PyPI): affected from 7.2rc1; fixed in 7.2.2
- wagtail (PyPI): affected from 7.2rc1; fixed in 7.2.2
- wagtail (PyPI): affected from 7.3rc1; fixed in 7.3
- wagtail (PyPI): affected from 7.3rc1; fixed in 7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25517/ (Markdown: https://insights.sbomify.com/CVE-2026-25517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25517
- OSV: https://osv.dev/vulnerability/CVE-2026-25517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25517/
Summaries are generated and may contain mistakes; the official description above is the record.
