# CVE-2026-25518: cert-manager-controller DoS via Specially Crafted DNS Response

> An attacker can cause a denial of service in the cert-manager controller by intercepting DNS traffic and injecting crafted entries that trigger a panic.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** BIT-cert-manager-2026-25518, CLEANSTART-2026-LX31883, CLEANSTART-2026-OJ21892, GHSA-gx3x-vq4p-mhhv, GO-2026-4399, MINI-334r-v2v4-mvqr, MINI-4hp9-7xj7-88wj, MINI-fqq8-g4c8-jw99, MINI-fwx2-p2gv-9gff, MINI-j5wr-8c7v-693q, MINI-p3x4-m78v-38fm, MINI-pr78-2365-c7rh, MINI-vp93-xx9v-hwqv

## What is CVE-2026-25518?

CVE-2026-25518 is a medium-severity denial of service vulnerability in cert-manager, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cert-manager adds certificates and certificate issuers as resource types in Kubernetes clusters, and simplifies the process of obtaining, renewing and using those certificates. In versions from 1.18.0 to before 1.18.5 and from 1.19.0 to before 1.19.3, the cert-manager-controller performs DNS lookups during ACME DNS-01 processing (for zone discovery and propagation self-checks). By default, these lookups use standard unencrypted DNS. An attacker who can intercept and modify DNS traffic from the cert-manager-controller pod can insert a crafted entry into cert-manager's DNS cache. Accessing this entry will trigger a panic, resulting in denial‑of‑service (DoS) of the cert-manager controller. The issue can also be exploited if the authoritative DNS server for the domain being validated is controlled by a malicious actor. This issue has been patched in versions 1.18.5 and 1.19.3.

Weakness: CWE-704 (Incorrect Type Conversion or Cast), CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-25518?

6 open source packages ship an affected version, including github.com/cert-manager/cert-manager and cert-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cert-manager/cert-manager` | Go | From 1.18.0 | 1.18.5, 1.19.3 |
| `github.com/cert-manager/cert-manager` | Go | From 1.18.0 | 1.18.5 |
| `github.com/cert-manager/cert-manager` | Go | From 1.18.0 | 1.18.5 |
| `github.com/cert-manager/cert-manager` | Go | From 1.19.0 | 1.19.3 |
| `github.com/cert-manager/cert-manager` | Go | From 1.19.0 | 1.19.3 |
| `cert-manager` | Bitnami | From 1.18.0 | 1.18.5, 1.19.3 |

Products: Cert-Manager Cert-Manager.

## How do I fix CVE-2026-25518?

Upgrade github.com/cert-manager/cert-manager to a fixed version for your release line: 1.18.5 or 1.19.3.

## Is CVE-2026-25518 being exploited?

There is no known exploitation of CVE-2026-25518 in the wild and no public exploit code.

## Other vulnerabilities in cert-manager

- [CVE-2024-36537](https://insights.sbomify.com/CVE-2024-36537/): Missing authorization in n/a (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25518 and fix it if it is affected.

What it is: CVE-2026-25518 is a medium-severity denial of service vulnerability in cert-manager, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25518 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cert-manager/cert-manager (Go): affected from 1.18.0; fixed in 1.18.5, 1.19.3
- github.com/cert-manager/cert-manager (Go): affected from 1.18.0; fixed in 1.18.5
- github.com/cert-manager/cert-manager (Go): affected from 1.18.0; fixed in 1.18.5
- github.com/cert-manager/cert-manager (Go): affected from 1.19.0; fixed in 1.19.3
- github.com/cert-manager/cert-manager (Go): affected from 1.19.0; fixed in 1.19.3
- cert-manager (Bitnami): affected from 1.18.0; fixed in 1.18.5, 1.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25518/ (Markdown: https://insights.sbomify.com/CVE-2026-25518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25518
- OSV: https://osv.dev/vulnerability/CVE-2026-25518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25518/
Summaries are generated and may contain mistakes; the official description above is the record.
