# CVE-2026-25525: OpenMage LTS has Path Traversal Filter Bypass in Dataflow Module

> An authenticated administrator can bypass path traversal filters in the Dataflow module to read arbitrary files from the server filesystem.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-6vqf-6fhm-7rc6

## What is CVE-2026-25525?

CVE-2026-25525 is a medium-severity path traversal vulnerability in OpenMage magento-lts, published on 20 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to version 20.17.0, the Dataflow module in OpenMage LTS uses a weak blacklist filter (`str_replace('../', '', $input)`) to prevent path traversal attacks. This filter can be bypassed using patterns like `..././` or `....//`, which after the replacement still result in `../`. An authenticated administrator can exploit this to read arbitrary files from the server filesystem. Version 20.17.0 patches the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-25525?

2 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 20.17.0 |
| `openmage/magento-lts` | Packagist | All versions | 20.17.0 |

Products: Openmage Magento.

## How do I fix CVE-2026-25525?

Upgrade openmage/magento-lts to 20.17.0 or later.

## Is CVE-2026-25525 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25525 exists.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25525 and fix it if it is affected.

What it is: CVE-2026-25525 is a medium-severity path traversal vulnerability in OpenMage magento-lts, published on 20 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25525 exists.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.17.0
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25525/ (Markdown: https://insights.sbomify.com/CVE-2026-25525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25525
- OSV: https://osv.dev/vulnerability/CVE-2026-25525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25525/
Summaries are generated and may contain mistakes; the official description above is the record.
