# CVE-2026-25529: Postal has HTML injection / XSS in message view

> Attackers can inject arbitrary HTML and JavaScript into the Postal admin interface via the send/raw API, potentially executing unauthorized scripts.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-5f4r-5jpr-rfhc

## What is CVE-2026-25529?

CVE-2026-25529 is a high-severity cross-site scripting vulnerability in postalserver postal, published on 12 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Postal is an open source SMTP server. Postal versions less than 3.3.5 had a HTML injection vulnerability that allowed unescaped data to be included in the admin interface. The primary way for unescaped data to be added is via the API's "send/raw" method. This could allow arbitrary HTML to be injected in to the page which may modify the page in a misleading way or allow for unauthorised javascript to be executed. Fixed in 3.3.5 and higher.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25529?

It affects 1 product.


Products: Postalserver Postal.

## How do I fix CVE-2026-25529?

No fix has been published for CVE-2026-25529 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25529 being exploited?

There is no known exploitation of CVE-2026-25529 in the wild and no public exploit code.

## Other vulnerabilities in postalserver postal

- [CVE-2024-27938](https://insights.sbomify.com/CVE-2024-27938/): SMTP Smuggling in Postal (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25529 and fix it if it is affected.

What it is: CVE-2026-25529 is a high-severity cross-site scripting vulnerability in postalserver postal, published on 12 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25529 in the wild and no public exploit code.

Affected product: postalserver postal. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25529/ (Markdown: https://insights.sbomify.com/CVE-2026-25529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25529
- OSV: https://osv.dev/vulnerability/CVE-2026-25529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25529/
Summaries are generated and may contain mistakes; the official description above is the record.
