# CVE-2026-25547: Uncontrolled Resource Consumption in @isaacs/brace-expansion

> Attackers can cause denial of service in applications using @isaacs/brace-expansion by submitting patterns that trigger exponential resource consumption.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** CLEANSTART-2026-RL65112, CLEANSTART-2026-UE38963, DEBIAN-CVE-2026-25547, ECHO-0199-0689-e425, GHSA-7h2j-956f-4vf2, MINI-3w7w-j3qj-4gc2, MINI-hh48-f422-qm76, MINI-p266-9pwx-xfcj, MINI-qqjv-7jcm-3f54, MINI-rf5r-cj3h-3m5g, MINI-rpcx-2jvq-vxww, MINI-vm6q-whrj-p9xc, ROOT-APP-NPM-CVE-2026-25547, UBUNTU-CVE-2026-25547, openSUSE-SU-2026:10168-1, openSUSE-SU-2026:10250-1, openSUSE-SU-2026:10251-1, openSUSE-SU-2026:10252-1, openSUSE-SU-2026:10253-1, openSUSE-SU-2026:10254-1, openSUSE-SU-2026:10268-1, openSUSE-SU-2026:10269-1, openSUSE-SU-2026:10428-1, openSUSE-SU-2026:20261-1

## What is CVE-2026-25547?

CVE-2026-25547 is a critical denial of service vulnerability in isaacs brace-expansion, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@isaacs/brace-expansion is a hybrid CJS/ESM TypeScript fork of brace-expansion. Prior to version 5.0.1, @isaacs/brace-expansion is vulnerable to a denial of service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. This issue has been patched in version 5.0.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-25547?

2 open source packages ship an affected version, including @isaacs/brace-expansion.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@isaacs/brace-expansion` | npm | All versions | 5.0.1 |
| `@isaacs/brace-expansion` | npm | All versions | 5.0.1 |
| `openQA` | openSUSE:Leap 16.0 | All versions | 5.1771422749.560a3b26-bp160.1.1 |
| `os-autoinst` | openSUSE:Leap 16.0 | All versions | 5.1771353921.c8005c9-bp160.1.1 |
| `cockpit` | openSUSE:Tumbleweed | All versions | 356-2.1 |
| `cockpit-machines` | openSUSE:Tumbleweed | All versions | 348-1.1 |
| `cockpit-packages` | openSUSE:Tumbleweed | All versions | 4.1-4.1 |
| `cockpit-podman` | openSUSE:Tumbleweed | All versions | 120-2.1 |
| `cockpit-repos` | openSUSE:Tumbleweed | All versions | 4.7-4.1 |
| `cockpit-subscriptions` | openSUSE:Tumbleweed | All versions | 14.4-4.1 |
| `cockpit-tukit` | openSUSE:Tumbleweed | All versions | 0.1.7~git0.61e54f1-3.1 |
| `openQA` | openSUSE:Tumbleweed | All versions | 5.1770718745.ce2072d3-1.1 |
| `python-jupyter-ydoc` | openSUSE:Tumbleweed | All versions | 3.4.0-2.1 |

## How do I fix CVE-2026-25547?

Upgrade @isaacs/brace-expansion to 5.0.1 or later.

## Is CVE-2026-25547 being exploited?

There is no known exploitation of CVE-2026-25547 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25547 and fix it if it is affected.

What it is: CVE-2026-25547 is a critical denial of service vulnerability in isaacs brace-expansion, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25547 in the wild and no public exploit code.

Affected packages and fixed versions:
- @isaacs/brace-expansion (npm): affected all versions; fixed in 5.0.1
- @isaacs/brace-expansion (npm): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25547/ (Markdown: https://insights.sbomify.com/CVE-2026-25547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25547
- OSV: https://osv.dev/vulnerability/CVE-2026-25547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25547/
Summaries are generated and may contain mistakes; the official description above is the record.
