# CVE-2026-25580: Pydantic AI Affected by Server-Side Request Forgery (SSRF) in URL Download Handling

> Attackers can exploit SSRF in Pydantic AI's URL download handling to access internal network resources or cloud credentials when accepting untrusted message history.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-2jrp-274c-jhv3, PYSEC-2026-2976, PYSEC-2026-2980

## What is CVE-2026-25580?

CVE-2026-25580 is a high-severity server-side request forgery vulnerability in pydantic-ai, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 0.0.26 to before 1.56.0, aServer-Side Request Forgery (SSRF) vulnerability exists in Pydantic AI's URL download functionality. When applications accept message history from untrusted sources, attackers can include malicious URLs that cause the server to make HTTP requests to internal network resources, potentially accessing internal services or cloud credentials. This vulnerability only affects applications that accept message history from external users. This vulnerability is fixed in 1.56.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-25580?

6 open source packages ship an affected version, including pydantic-ai and pydantic-ai-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pydantic-ai` | PyPI | From 0.0.26 | 1.56.0 |
| `pydantic-ai` | PyPI | From 0.0.26 | 1.56.0 |
| `pydantic-ai` | PyPI | From 0.0.26 | 1.56.0 |
| `pydantic-ai-slim` | PyPI | From 0.0.26 | 1.56.0 |
| `pydantic-ai-slim` | PyPI | From 0.0.26 | 1.56.0 |
| `pydantic-ai-slim` | PyPI | From 0.0.26 | 1.56.0 |

Products: Pydantic Pydantic Ai.

## How do I fix CVE-2026-25580?

Upgrade pydantic-ai to 1.56.0 or later.

## Is CVE-2026-25580 being exploited?

There is no known exploitation of CVE-2026-25580 in the wild and no public exploit code.

## Other vulnerabilities in pydantic-ai

- [CVE-2026-107295](https://insights.sbomify.com/CVE-2026-107295/): Pydantic AI Web chat UI (`Agent.to_web()`, `clai web`): a website visited by the developer can trigger agent runs and server-side tool execution on the local chat endpoint (high 7.6)
- [CVE-2026-107286](https://insights.sbomify.com/CVE-2026-107286/): Pydantic AI: Concurrency-limited models can keep their slot when a streamed request ends early (high 7.5)
- [CVE-2026-25640](https://insights.sbomify.com/CVE-2026-25640/): Pydantic AI affected by Stored XSS via Path Traversal in Web UI CDN URL (high 7.1)
- [CVE-2026-107289](https://insights.sbomify.com/CVE-2026-107289/): Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv6 zone identifiers (medium 6.8)
- [CVE-2026-46678](https://insights.sbomify.com/CVE-2026-46678/): Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv4-mapped IPv6 (Incomplete fix of CVE-2026-25580) (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25580 and fix it if it is affected.

What it is: CVE-2026-25580 is a high-severity server-side request forgery vulnerability in pydantic-ai, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25580 in the wild and no public exploit code.

Affected packages and fixed versions:
- pydantic-ai (PyPI): affected from 0.0.26; fixed in 1.56.0
- pydantic-ai (PyPI): affected from 0.0.26; fixed in 1.56.0
- pydantic-ai (PyPI): affected from 0.0.26; fixed in 1.56.0
- pydantic-ai-slim (PyPI): affected from 0.0.26; fixed in 1.56.0
- pydantic-ai-slim (PyPI): affected from 0.0.26; fixed in 1.56.0
- pydantic-ai-slim (PyPI): affected from 0.0.26; fixed in 1.56.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25580/ (Markdown: https://insights.sbomify.com/CVE-2026-25580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25580
- OSV: https://osv.dev/vulnerability/CVE-2026-25580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25580/
Summaries are generated and may contain mistakes; the official description above is the record.
