{"answers":{"affected":"2 open source packages ship an affected version, including sceditor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-25581 in the wild and no public exploit code.","fix":"Upgrade sceditor to 3.2.1 or later.","what":"CVE-2026-25581 is a medium-severity cross-site scripting vulnerability in samclarke SCEditor, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-25581 and fix it if it is affected.\n\nWhat it is: CVE-2026-25581 is a medium-severity cross-site scripting vulnerability in samclarke SCEditor, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-25581 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sceditor (npm): affected all versions; fixed in 3.2.1\n- sceditor (npm): affected all versions; fixed in 3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25581/ (Markdown: https://insights.sbomify.com/CVE-2026-25581/index.md)","id":"CVE-2026-25581","markdown":"https://insights.sbomify.com/CVE-2026-25581/index.md","name":"CVE-2026-25581","record":{"aliases":["GHSA-25fq-6qgg-qpj8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript WYSIWYG editor","requires_auth":"low_privilege","summary":"An attacker controlling editor configuration options can inject malicious HTML or URLs to trigger DOM-based Cross-Site Scripting in SCEditor.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sceditor","vendor":"sceditor"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"SCEditor is a lightweight WYSIWYG BBCode and XHTML editor. Prior to 3.2.1, if an attacker has the ability control configuration options passed to sceditor.create(), like emoticons, charset, etc. then it's possible for them to trigger an XSS attack due to lack of sanitisation of configuration options. This vulnerability is fixed in 3.2.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SCEditor affected by DOM XSS via emoticon URL/HTML injection","id":"CVE-2026-25581","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"iccDEV vulnerable to Heap Buffer Overflow in CIccIO::WriteUInt16Float()","id":"CVE-2026-25582"},"packages":[{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"sceditor","purl":null,"source":"GHSA-25fq-6qgg-qpj8"},{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"sceditor","purl":"pkg:npm/sceditor","source":"GHSA-25fq-6qgg-qpj8"}],"prev":{"headline":"Pydantic AI Affected by Server-Side Request Forgery (SSRF) in URL Download Handling","id":"CVE-2026-25580"},"products":["SCEditor"],"published":"2026-02-06","related":[{"cvss_score":6.1,"headline":"SCEditor 2.1.3 allows XSS.","id":"CVE-2019-19466","kev_date_added":null,"published":"2019-12-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-09","vendors":["samclarke"]},"summary":"An attacker controlling editor configuration options can inject malicious HTML or URLs to trigger DOM-based Cross-Site Scripting in SCEditor.","url":"https://insights.sbomify.com/CVE-2026-25581/"}