# CVE-2026-25581: SCEditor affected by DOM XSS via emoticon URL/HTML injection

> An attacker controlling editor configuration options can inject malicious HTML or URLs to trigger DOM-based Cross-Site Scripting in SCEditor.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-25fq-6qgg-qpj8

## What is CVE-2026-25581?

CVE-2026-25581 is a medium-severity cross-site scripting vulnerability in samclarke SCEditor, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

SCEditor is a lightweight WYSIWYG BBCode and XHTML editor. Prior to 3.2.1, if an attacker has the ability control configuration options passed to sceditor.create(), like emoticons, charset, etc. then it's possible for them to trigger an XSS attack due to lack of sanitisation of configuration options. This vulnerability is fixed in 3.2.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25581?

2 open source packages ship an affected version, including sceditor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sceditor` | npm | All versions | 3.2.1 |
| `sceditor` | npm | All versions | 3.2.1 |

Products: Sceditor Sceditor.

## How do I fix CVE-2026-25581?

Upgrade sceditor to 3.2.1 or later.

## Is CVE-2026-25581 being exploited?

There is no known exploitation of CVE-2026-25581 in the wild and no public exploit code.

## Other vulnerabilities in samclarke SCEditor

- [CVE-2019-19466](https://insights.sbomify.com/CVE-2019-19466/): SCEditor 2.1.3 allows XSS. (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25581 and fix it if it is affected.

What it is: CVE-2026-25581 is a medium-severity cross-site scripting vulnerability in samclarke SCEditor, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25581 in the wild and no public exploit code.

Affected packages and fixed versions:
- sceditor (npm): affected all versions; fixed in 3.2.1
- sceditor (npm): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25581/ (Markdown: https://insights.sbomify.com/CVE-2026-25581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25581
- OSV: https://osv.dev/vulnerability/CVE-2026-25581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25581/
Summaries are generated and may contain mistakes; the official description above is the record.
