# CVE-2026-25588: RedisTimeSeries RESTORE invalid memory access may allow remote code execution

> An authenticated attacker can trigger remote code execution via invalid memory access in the RedisTimeSeries module's RESTORE command.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 6 May 2026
- **Also known as:** BIT-keydb-2026-25588, BIT-redis-2026-25588, GHSA-7jwr-g5qv-w3gw, MINI-8f2c-4c4m-fx5m, MINI-j93f-hf7h-446p, MINI-wcvf-62qq-vj8w, MINI-wrcp-v6m6-v4cx, UBUNTU-CVE-2026-25588

## What is CVE-2026-25588?

CVE-2026-25588 is a high-severity memory corruption vulnerability in RedisTimeSeries, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RedisTimeSeries is a time-series module for Redis. In all versions before 1.12.14 of RedisTimeSeries, the module does not properly validate serialized values processed through the Redis RESTORE command. An authenticated attacker with permission to execute RESTORE on a server with the RedisTimeSeries module loaded can supply a crafted serialized payload that triggers invalid memory access and may lead to remote code execution. A workaround is to restrict access to the RESTORE command with ACL rules. This has been patched in version 1.12.14.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-25588?

2 open source packages ship an affected version, including keydb and redis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keydb` | Bitnami | From 8.0.0 | 8.2.6, 8.4.3, 8.6.3 |
| `redis` | Bitnami | From 8.0.0 | 8.2.6, 8.4.3, 8.6.3 |

Products: Redistimeseries Redistimeseries.

## How do I fix CVE-2026-25588?

Upgrade keydb to a fixed version for your release line: 8.2.6, 8.4.3 or 8.6.3.

## Is CVE-2026-25588 being exploited?

There is no known exploitation of CVE-2026-25588 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25588 and fix it if it is affected.

What it is: CVE-2026-25588 is a high-severity memory corruption vulnerability in RedisTimeSeries, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25588 in the wild and no public exploit code.

Affected packages and fixed versions:
- keydb (Bitnami): affected from 8.0.0; fixed in 8.2.6, 8.4.3, 8.6.3
- redis (Bitnami): affected from 8.0.0; fixed in 8.2.6, 8.4.3, 8.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25588/ (Markdown: https://insights.sbomify.com/CVE-2026-25588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25588
- OSV: https://osv.dev/vulnerability/CVE-2026-25588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25588/
Summaries are generated and may contain mistakes; the official description above is the record.
