# CVE-2026-25591: New API has an SQL LIKE Wildcard Injection DoS via Token Search

> Authenticated users can cause denial of service in New API by injecting SQL wildcards into token search parameters, exhausting database resources.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-w6x6-9fp7-fqm4, GO-2026-4531

## What is CVE-2026-25591?

CVE-2026-25591 is a high-severity denial of service vulnerability in QuantumNous new-api, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Prior to version 0.10.8-alpha.10, a SQL LIKE wildcard injection vulnerability in the `/api/token/search` endpoint allows authenticated users to cause denial of service through resource exhaustion by crafting malicious search patterns. The token search endpoint accepts user-supplied `keyword` and `token` parameters that are directly concatenated into SQL LIKE clauses without escaping wildcard characters (`%`, `_`). This allows attackers to inject patterns that trigger expensive database queries. Version 0.10.8-alpha.10 contains a patch.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic)

## Which versions are affected by CVE-2026-25591?

3 open source packages ship an affected version, including github.com/QuantumNous/new-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.10.8-alpha.10 |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.10.8-alpha.10 |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.10.8-alpha.10 |

Products: Newapi New Api.

## How do I fix CVE-2026-25591?

Upgrade github.com/QuantumNous/new-api to 0.10.8-alpha.10 or later.

## Is CVE-2026-25591 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25591 exists.

## Other vulnerabilities in QuantumNous new-api

- [CVE-2025-55573](https://insights.sbomify.com/CVE-2025-55573/): Cross-site scripting in n/a (high 8.8)
- [CVE-2026-33655](https://insights.sbomify.com/CVE-2026-33655/): New API: SSRF Protection Bypass via Unresolved Hostname in Notification URLs (high 7.7)
- [CVE-2026-25802](https://insights.sbomify.com/CVE-2026-25802/): New API has Potential XSS in its MarkdownRenderer component (high 7.6)
- [CVE-2026-41432](https://insights.sbomify.com/CVE-2026-41432/): New API: Stripe Webhook Signature Bypass via Empty Secret Enables Unlimited Quota Fraud (high 7.1)
- [CVE-2026-42339](https://insights.sbomify.com/CVE-2026-42339/): New API: SSRF Filter Bypass via 0.0.0.0 (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25591 and fix it if it is affected.

What it is: CVE-2026-25591 is a high-severity denial of service vulnerability in QuantumNous new-api, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25591 exists.

Affected packages and fixed versions:
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.10.8-alpha.10
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.10.8-alpha.10
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.10.8-alpha.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25591/ (Markdown: https://insights.sbomify.com/CVE-2026-25591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25591
- OSV: https://osv.dev/vulnerability/CVE-2026-25591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25591/
Summaries are generated and may contain mistakes; the official description above is the record.
