CVE-2026-25593 OpenClaw Affected by Unauthenticated Local RCE via WebSocket config.apply
Unauthenticated local attackers can execute arbitrary commands by injecting unsafe paths via the WebSocket config API.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25593?
CVE-2026-25593 is a high-severity command injection vulnerability in Openclaw Openclaw, published on 6 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
OpenClaw is a personal AI assistant. Prior to 2026.1.20, an unauthenticated local client could use the Gateway WebSocket API to write config via config.apply and set unsafe cliPath values that were later used for command discovery, enabling command injection as the gateway user. This vulnerability is fixed in 2026.1.20.
Which versions are affected by CVE-2026-25593?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.1.20 |
openclaw npm | All versions | 2026.1.20 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-25593?
Upgrade openclaw to 2026.1.20 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-25593 being exploited?
There is no known exploitation of CVE-2026-25593 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-g55j-c2v4-pjcg.