# CVE-2026-25631: Domain allowlist bypass enables credential exfiltration

> Authenticated attackers can bypass domain allowlists in n8n to exfiltrate credentials if wildcard patterns are used in allowed domains.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** GHSA-2xcx-75h9-vr9h

## What is CVE-2026-25631?

CVE-2026-25631 is a medium-severity vulnerability in N8n N8n, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to 1.121.0, there is a vulnerability in the HTTP Request node's credential domain validation allowed an authenticated attacker to send requests with credentials to unintended domains, potentially leading to credential exfiltration. This only might affect user who have credentials that use wildcard domain patterns (e.g., *.example.com) in the "Allowed domains" setting. This issue is fixed in version 1.121.0 and later.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-25631?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.121.0 |
| `n8n` | npm | All versions | 1.121.0 |

Products: N8n N8n.

## How do I fix CVE-2026-25631?

Upgrade n8n to 1.121.0 or later.

## Is CVE-2026-25631 being exploited?

There is no known exploitation of CVE-2026-25631 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25631 and fix it if it is affected.

What it is: CVE-2026-25631 is a medium-severity vulnerability in N8n N8n, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25631 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.121.0
- n8n (npm): affected all versions; fixed in 1.121.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25631/ (Markdown: https://insights.sbomify.com/CVE-2026-25631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25631
- OSV: https://osv.dev/vulnerability/CVE-2026-25631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25631/
Summaries are generated and may contain mistakes; the official description above is the record.
