# CVE-2026-25639: Axios affected by Denial of Service via __proto__ Key in mergeConfig

> An attacker can cause a denial of service in Axios by providing a configuration object with a __proto__ key, crashing the application.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-JD21137, CLEANSTART-2026-ZH04273, CLSA-2026-1776904633, CLSA-2026-1778028254, CLSA-2026-1792164130, DEBIAN-CVE-2026-25639, ECHO-0c78-6288-0124, GHSA-43fc-jf86-j433, MINI-24wp-mv3c-4r8c, MINI-39xx-pf4v-qfj5, MINI-3j4c-x6cq-cvg3, MINI-5hf6-m9jh-mwq3, MINI-76jx-cfgf-gwgv, MINI-9xx7-9cgc-h69v, MINI-chvf-pjxp-2g76, MINI-cxgv-p8m5-f898, MINI-f5r4-vr9g-x5hj, MINI-q9wf-h9pf-4c96, MINI-qhx4-65m4-w82c, MINI-qrvp-88jx-wwjq, MINI-r9f6-4jpp-r2p2, MINI-w4j8-47v6-m2f5, ROOT-APP-NPM-CVE-2026-25639, UBUNTU-CVE-2026-25639

## What is CVE-2026-25639?

CVE-2026-25639 is a high-severity denial of service vulnerability in axios, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to versions 0.30.3 and 1.13.5, the mergeConfig function in axios crashes with a TypeError when processing configuration objects containing __proto__ as an own property. An attacker can trigger this by providing a malicious configuration object created via JSON.parse(), causing complete denial of service. This vulnerability is fixed in versions 0.30.3 and 1.13.5.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input), CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-25639?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.30.3 |
| `axios` | npm | All versions | 0.30.3 |
| `axios` | npm | From 1.0.0 | 1.13.5 |
| `axios` | npm | From 1.0.0 | 1.13.5 |

Products: Axios Axios.

## How do I fix CVE-2026-25639?

Upgrade axios to a fixed version for your release line: 0.30.3 or 1.13.5.

## Is CVE-2026-25639 being exploited?

There is no known exploitation of CVE-2026-25639 in the wild and no public exploit code.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25639 and fix it if it is affected.

What it is: CVE-2026-25639 is a high-severity denial of service vulnerability in axios, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25639 in the wild and no public exploit code.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.30.3
- axios (npm): affected all versions; fixed in 0.30.3
- axios (npm): affected from 1.0.0; fixed in 1.13.5
- axios (npm): affected from 1.0.0; fixed in 1.13.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25639/ (Markdown: https://insights.sbomify.com/CVE-2026-25639/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25639
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25639
- OSV: https://osv.dev/vulnerability/CVE-2026-25639

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25639/
Summaries are generated and may contain mistakes; the official description above is the record.
