CVE-2026-25640 Pydantic AI affected by Stored XSS via Path Traversal in Web UI CDN URL

High 7.1 Published Updated

Attackers can execute arbitrary JavaScript in victims' browsers via path traversal in the web UI CDN URL, stealing chat history and client-side data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-25640?

CVE-2026-25640 is a high-severity cross-site scripting vulnerability in pydantic-ai, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 1.34.0 to before 1.51.0, a path traversal vulnerability in the Pydantic AI web UI allows an attacker to serve arbitrary JavaScript in the context of the application by crafting a malicious URL. In affected versions, the CDN URL is constructed using a version query parameter from the request URL. This parameter is not validated, allowing path traversal sequences that cause the server to fetch and serve attacker-controlled HTML/JavaScript from an arbitrary source on the same CDN, instead of the legitimate chat UI package. If a victim clicks the link or visits it via an iframe, attacker-controlled code executes in their browser, enabling theft of chat history and other client-side data. This vulnerability only affects applications that use Agent.to_web to serve a chat interface and clai web to serve a chat interface from the CLI. These are typically run locally (on localhost), but may also be deployed on a remote server. This vulnerability is fixed in 1.51.0.

Weakness: CWE-79, CWE-22

Which versions are affected by CVE-2026-25640?

6 open source packages ship an affected version, including pydantic-ai and pydantic-ai-slim. It affects 1 product.

PackageAffectedFixed in
pydantic-ai PyPIFrom 1.34.01.51.0
pydantic-ai PyPIFrom 1.34.01.51.0
pydantic-ai PyPIFrom 1.34.01.51.0
pydantic-ai-slim PyPIFrom 1.34.01.51.0
pydantic-ai-slim PyPIFrom 1.34.01.51.0
pydantic-ai-slim PyPIFrom 1.34.01.51.0

Products include Pydantic Pydantic Ai.

How do I fix CVE-2026-25640?

Upgrade pydantic-ai to 1.51.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-25640 being exploited?

There is no known exploitation of CVE-2026-25640 in the wild and no public exploit code.

Sources

Also known as GHSA-wjp5-868j-wqv7, PYSEC-2026-2979, PYSEC-2026-2983.

Is CVE-2026-25640 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free