# CVE-2026-25643: Frigate Affected by Authenticated Remote Command Execution (RCE) and Container Escape

> Administrators or unauthenticated users on exposed instances can execute arbitrary system commands via unsanitized video stream configuration inputs.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** GHSA-4c97-5jmr-8f6x

## What is CVE-2026-25643?

CVE-2026-25643 is a critical command injection vulnerability in blakeblackshear frigate, published on 6 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Frigate is a network video recorder (NVR) with realtime local object detection for IP cameras. Prior to 0.16.4, a critical Remote Command Execution (RCE) vulnerability has been identified in the Frigate integration with go2rtc. The application does not sanitize user input in the video stream configuration (config.yaml), allowing direct injection of system commands via the exec: directive. The go2rtc service executes these commands without restrictions. This vulnerability is only exploitable by an administrator or users who have exposed their Frigate install to the open internet with no authentication which allows anyone full administrative control. This vulnerability is fixed in 0.16.4.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-668 (Exposure of Resource to Wrong Sphere), CWE-269 (Improper Privilege Management), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2026-25643?

It affects 1 product.


Products: Frigate Frigate.

## How do I fix CVE-2026-25643?

No fix has been published for CVE-2026-25643 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25643 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25643 exists.

Public exploit code:

- CVE-2026-25643: Frigate ≤0.16.3 Blind RCE via go2rtc exec injection (github_poc): https://github.com/joshuavanderpoll/CVE-2026-25643
- https://github.com/jduardo2704/CVE-2026-25643-Frigate-RCE (github_poc): https://github.com/jduardo2704/CVE-2026-25643-Frigate-RCE
- Frigate NVR 0.16.3 - Remote Code Execution (exploitdb)

## Other vulnerabilities in blakeblackshear frigate

- [CVE-2026-33124](https://insights.sbomify.com/CVE-2026-33124/): Frigate has insecure password change functionality (high 8.6)
- [CVE-2023-45670](https://insights.sbomify.com/CVE-2023-45670/): Frigate cross-site request forgery in `config_save` and `config_set` request handlers (high 7.5)
- [CVE-2023-45672](https://insights.sbomify.com/CVE-2023-45672/): Frigate unsafe deserialization in `load_config_with_no_duplicates` of `frigate/util/builtin.py` (high 7.5)
- [CVE-2026-33125](https://insights.sbomify.com/CVE-2026-33125/): Frigate Broken Access Control: Users assigned the viewer role can delete admin and other low-privileged accounts (high 7.1)
- [CVE-2026-33469](https://insights.sbomify.com/CVE-2026-33469/): Authenticated Frigate users can read the full unredacted configuration via `/api/config/raw (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25643 and fix it if it is affected.

What it is: CVE-2026-25643 is a critical command injection vulnerability in blakeblackshear frigate, published on 6 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25643 exists.

Affected product: blakeblackshear frigate. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25643/ (Markdown: https://insights.sbomify.com/CVE-2026-25643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25643
- OSV: https://osv.dev/vulnerability/CVE-2026-25643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25643/
Summaries are generated and may contain mistakes; the official description above is the record.
