# CVE-2026-25650: MCP Salesforce Connector has arbitrary attribute access which leads to disclosure of Salesforce auth token

> An attacker can access arbitrary attributes to disclose the Salesforce auth token in the MCP Salesforce Connector library.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-vf6j-c56p-cq58, PYSEC-2026-2629

## What is CVE-2026-25650?

CVE-2026-25650 is a medium-severity vulnerability in smn2gnt MCP-Salesforce, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MCP Salesforce Connector is a Model Context Protocol (MCP) server implementation for Salesforce integration. Prior to 0.1.10, arbitrary attribute access leads to disclosure of Salesforce auth token. This vulnerability is fixed in 0.1.10.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-25650?

3 open source packages ship an affected version, including mcp-salesforce-connector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-salesforce-connector` | PyPI | All versions | 0.1.10 |
| `mcp-salesforce-connector` | PyPI | All versions | 0.1.10 |
| `mcp-salesforce-connector` | PyPI | All versions | 0.1.10 |

Products: Smn2gnt Mcp Salesforce Connector.

## How do I fix CVE-2026-25650?

Upgrade mcp-salesforce-connector to 0.1.10 or later.

## Is CVE-2026-25650 being exploited?

There is no known exploitation of CVE-2026-25650 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25650 and fix it if it is affected.

What it is: CVE-2026-25650 is a medium-severity vulnerability in smn2gnt MCP-Salesforce, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25650 in the wild and no public exploit code.

Affected packages and fixed versions:
- mcp-salesforce-connector (PyPI): affected all versions; fixed in 0.1.10
- mcp-salesforce-connector (PyPI): affected all versions; fixed in 0.1.10
- mcp-salesforce-connector (PyPI): affected all versions; fixed in 0.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25650/ (Markdown: https://insights.sbomify.com/CVE-2026-25650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25650
- OSV: https://osv.dev/vulnerability/CVE-2026-25650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25650/
Summaries are generated and may contain mistakes; the official description above is the record.
