# CVE-2026-25651: client-certificate-auth has an Open Redirect via Host Header Injection in HTTP-to-HTTPS redirect

> An attacker can redirect users to arbitrary domains via Host Header Injection in the HTTP-to-HTTPS redirect logic of this Node.js middleware.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-m4w9-gch5-c2g4

## What is CVE-2026-25651?

CVE-2026-25651 is a medium-severity vulnerability in tgies client-certificate-auth, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

client-certificate-auth is middleware for Node.js implementing client SSL certificate authentication/authorization. Versions 0.2.1 and 0.3.0 of client-certificate-auth contain an open redirect vulnerability. The middleware unconditionally redirects HTTP requests to HTTPS using the unvalidated Host header, allowing an attacker to redirect users to arbitrary domains. This vulnerability is fixed in 1.0.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-25651?

2 open source packages ship an affected version, including client-certificate-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `client-certificate-auth` | npm | From 0.2.1 | 1.0.0 |
| `client-certificate-auth` | npm | From 0.2.1 | 1.0.0 |

Products: Tgies Client-Certificate-Auth.

## How do I fix CVE-2026-25651?

Upgrade client-certificate-auth to 1.0.0 or later.

## Is CVE-2026-25651 being exploited?

There is no known exploitation of CVE-2026-25651 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25651 and fix it if it is affected.

What it is: CVE-2026-25651 is a medium-severity vulnerability in tgies client-certificate-auth, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25651 in the wild and no public exploit code.

Affected packages and fixed versions:
- client-certificate-auth (npm): affected from 0.2.1; fixed in 1.0.0
- client-certificate-auth (npm): affected from 0.2.1; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25651/ (Markdown: https://insights.sbomify.com/CVE-2026-25651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25651
- OSV: https://osv.dev/vulnerability/CVE-2026-25651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25651/
Summaries are generated and may contain mistakes; the official description above is the record.
