CVE-2026-25674 Potential incorrect permissions on newly created file system objects
A race condition in Django's file storage allows attackers to create files with incorrect permissions, potentially leading to privilege escalation or data exposure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25674?
CVE-2026-25674 is a low-severity vulnerability in Djangoproject Django, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in 6.0 before 6.0.3, 5.2 before 5.2.12, and 4.2 before 4.2.29. Race condition in file-system storage and file-based cache backends in Django allows an attacker to cause file system objects to be created with incorrect permissions via concurrent requests, where one thread's temporary `umask` change affects other threads in multi-threaded environments. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Tarek Nakkouch for reporting this issue.
Weakness: CWE-362
Which versions are affected by CVE-2026-25674?
8 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.29, 5.2.12, 6.0.3 |
django PyPI | From 4.2 | 4.2.29, 5.2.12, 6.0.3 |
django PyPI | From 4.2 | 4.2.29 |
django PyPI | From 5.2 | 5.2.12 |
django PyPI | From 6.0 | 6.0.3 |
Django PyPI | From 4.2 | 4.2.29 |
2 more packages
Django PyPI | From 5.2 | 5.2.12 |
Django PyPI | From 6.0 | 6.0.3 |
Linux distribution packages (6)
python-Django SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.50.1 |
python-Django openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.50.1 |
python-Django openSUSE:Leap 16.0 | All versions | 5.2.4-bp160.6.1 |
python-Django openSUSE:Tumbleweed | All versions | 5.2.12-1.1 |
python-Django4 openSUSE:Tumbleweed | All versions | 4.2.29-1.1 |
python-Django6 openSUSE:Tumbleweed | All versions | 6.0.3-1.1 |
Products include Djangoproject Django.
How do I fix CVE-2026-25674?
Upgrade django to a fixed version for your release line: 4.2.29, 5.2.12 or 6.0.3.
Is CVE-2026-25674 being exploited?
There is no known exploitation of CVE-2026-25674 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2026-25674, DEBIAN-CVE-2026-25674, ECHO-f85d-c4a6-6f1f, GHSA-mjgh-79qc-68w3, MGASA-2026-0050, MINI-c95x-c5hr-25p9 and 12 more.