# CVE-2026-25674: Potential incorrect permissions on newly created file system objects

> A race condition in Django's file storage allows attackers to create files with incorrect permissions, potentially leading to privilege escalation or data exposure.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2026
- **Updated:** 3 Mar 2026
- **Also known as:** BIT-django-2026-25674, DEBIAN-CVE-2026-25674, ECHO-f85d-c4a6-6f1f, GHSA-mjgh-79qc-68w3, MGASA-2026-0050, MINI-c95x-c5hr-25p9, OESA-2026-1506, OESA-2026-1508, OESA-2026-1509, OESA-2026-1510, OESA-2026-1511, PYSEC-2026-2449, SUSE-SU-2026:0821-1, UBUNTU-CVE-2026-25674, openSUSE-SU-2026:10282-1, openSUSE-SU-2026:10283-1, openSUSE-SU-2026:10292-1, openSUSE-SU-2026:20373-1

## What is CVE-2026-25674?

CVE-2026-25674 is a low-severity vulnerability in Djangoproject Django, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in 6.0 before 6.0.3, 5.2 before 5.2.12, and 4.2 before 4.2.29.
Race condition in file-system storage and file-based cache backends in Django allows an attacker to cause file system objects to be created with incorrect permissions via concurrent requests, where one thread's temporary `umask` change affects other threads in multi-threaded environments.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Tarek Nakkouch for reporting this issue.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-25674?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.29, 5.2.12, 6.0.3 |
| `django` | PyPI | From 4.2 | 4.2.29, 5.2.12, 6.0.3 |
| `django` | PyPI | From 4.2 | 4.2.29 |
| `django` | PyPI | From 5.2 | 5.2.12 |
| `django` | PyPI | From 6.0 | 6.0.3 |
| `Django` | PyPI | From 4.2 | 4.2.29 |
| `Django` | PyPI | From 5.2 | 5.2.12 |
| `Django` | PyPI | From 6.0 | 6.0.3 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.50.1 |
| `python-Django` | openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.50.1 |
| `python-Django` | openSUSE:Leap 16.0 | All versions | 5.2.4-bp160.6.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 5.2.12-1.1 |
| `python-Django4` | openSUSE:Tumbleweed | All versions | 4.2.29-1.1 |
| `python-Django6` | openSUSE:Tumbleweed | All versions | 6.0.3-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2026-25674?

Upgrade django to a fixed version for your release line: 4.2.29, 5.2.12 or 6.0.3.

## Is CVE-2026-25674 being exploited?

There is no known exploitation of CVE-2026-25674 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25674 and fix it if it is affected.

What it is: CVE-2026-25674 is a low-severity vulnerability in Djangoproject Django, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25674 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.29, 5.2.12, 6.0.3
- django (PyPI): affected from 4.2; fixed in 4.2.29, 5.2.12, 6.0.3
- django (PyPI): affected from 4.2; fixed in 4.2.29
- django (PyPI): affected from 5.2; fixed in 5.2.12
- django (PyPI): affected from 6.0; fixed in 6.0.3
- Django (PyPI): affected from 4.2; fixed in 4.2.29
- Django (PyPI): affected from 5.2; fixed in 5.2.12
- Django (PyPI): affected from 6.0; fixed in 6.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25674/ (Markdown: https://insights.sbomify.com/CVE-2026-25674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25674
- OSV: https://osv.dev/vulnerability/CVE-2026-25674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25674/
Summaries are generated and may contain mistakes; the official description above is the record.
