# CVE-2026-25700: Apache Answer: AdminToken not invalidated after admin deactivation

> Deactivated administrators retain access to administrative APIs via unrevoked tokens, allowing unauthorized privileged actions until token expiration.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 19 Jun 2026
- **Also known as:** GHSA-4gw2-vg4x-7p29, GO-2026-6249

## What is CVE-2026-25700?

CVE-2026-25700 is a high-severity authentication bypass vulnerability in Apache Answer, published on 10 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Restriction of Security Token Assignment vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.0.

Previously issued administrative tokens were not invalidated after an administrator account was suspended, deleted, or deactivated, allowing continued access to administrative APIs until the token expired.
Users are recommended to upgrade to version 2.0.1, which fixes the issue.

Weakness: CWE-1259 (Improper Restriction of Security Token Assignment)

## Which versions are affected by CVE-2026-25700?

6 open source packages ship an affected version, including github.com/apache/answer and github.com/apache/incubator-answer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/answer` | Go | All versions | None |
| `github.com/apache/answer` | Go | All versions | 2.0.1 |
| `github.com/apache/answer` | Go | All versions | 2.0.1 |
| `github.com/apache/incubator-answer` | Go | All versions | None |
| `github.com/apache/incubator-answer` | Go | All versions | 2.0.1 |
| `github.com/apache/incubator-answer` | Go | All versions | 2.0.1 |

Products: Apache Answer.

## How do I fix CVE-2026-25700?

Upgrade github.com/apache/answer to 2.0.1 or later.

## Is CVE-2026-25700 being exploited?

There is no known exploitation of CVE-2026-25700 in the wild and no public exploit code.

## Other vulnerabilities in Apache Answer

- [CVE-2026-60053](https://insights.sbomify.com/CVE-2026-60053/): Apache Answer: Residual Administrative API Key Access After Role or Account Revocation (critical 9.1)
- [CVE-2024-22393](https://insights.sbomify.com/CVE-2024-22393/): Apache Answer: Pixel Flood Attack by uploading the large pixel file (critical 9.1)
- [CVE-2026-48834](https://insights.sbomify.com/CVE-2026-48834/): Apache Answer: Denial of service via crafted Accept-Language header parsing (high 7.5)
- [CVE-2026-48911](https://insights.sbomify.com/CVE-2026-48911/): Apache Answer: Unauthenticated OAuth Email-Binding Account Takeover via Existing User Confirmation Flow (high 7.5)
- [CVE-2026-60023](https://insights.sbomify.com/CVE-2026-60023/): Apache Answer: Unauthorized disclosure of deleted or pending answer content (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25700 and fix it if it is affected.

What it is: CVE-2026-25700 is a high-severity authentication bypass vulnerability in Apache Answer, published on 10 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25700 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/answer (Go): affected all versions; no fix listed
- github.com/apache/answer (Go): affected all versions; fixed in 2.0.1
- github.com/apache/answer (Go): affected all versions; fixed in 2.0.1
- github.com/apache/incubator-answer (Go): affected all versions; no fix listed
- github.com/apache/incubator-answer (Go): affected all versions; fixed in 2.0.1
- github.com/apache/incubator-answer (Go): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25700/ (Markdown: https://insights.sbomify.com/CVE-2026-25700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25700
- OSV: https://osv.dev/vulnerability/CVE-2026-25700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25700/
Summaries are generated and may contain mistakes; the official description above is the record.
