{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-25707 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-25707 is a high-severity path traversal vulnerability in SUSE libzypp, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-25707 and fix it if it is affected.\n\nWhat it is: CVE-2026-25707 is a high-severity path traversal vulnerability in SUSE libzypp, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-25707 in the wild and no public exploit code.\n\nAffected product: SUSE libzypp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25707/ (Markdown: https://insights.sbomify.com/CVE-2026-25707/index.md)","id":"CVE-2026-25707","markdown":"https://insights.sbomify.com/CVE-2026-25707/index.md","name":"CVE-2026-25707","record":{"aliases":["DEBIAN-CVE-2026-25707","GHSA-4h5m-3w75-qcq5","UBUNTU-CVE-2026-25707","openSUSE-SU-2026:10896-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libzypp package manager","requires_auth":"none","summary":"Remote attackers can overwrite local files via malicious repository metadata in libzypp, potentially causing denial of service or privilege escalation.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"libzypp","vendor":"opensuse"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"A relative path traversal bug problem when processing repository metadata in libzypp before 17.38.10 could be used by remote attackers supplying repositories to overwrite files on the system, leading to denial of service or privilege escalation.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Handcrafted repo metadata may cause arbitrary local files to be overwritten by libzypp","id":"CVE-2026-25707","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Privilege escalation in plasma-login-manager","id":"CVE-2026-25710"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["17.38.10-1.1"],"introduced":["0"],"last_affected":[],"package":"libzypp","purl":"pkg:rpm/opensuse/libzypp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10896-1"}],"prev":{"headline":"yast2-samba-client: OS command injection via attacker-controlled Organizational Unit (Active Directory-supplied)","id":"CVE-2026-25706"},"products":["libzypp"],"published":"2026-06-29","related":[{"cvss_score":8.4,"headline":"libzypp path traversal via \"keyhint\" in repomd.xml","id":"CVE-2026-44941","kev_date_added":null,"published":"2026-07-02"},{"cvss_score":8.1,"headline":"libzypp accepts unsigned 3rd party repo without warning","id":"CVE-2017-7435","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":8.1,"headline":"libzypp accepts unsigned packages even when configured to check signatures","id":"CVE-2017-7436","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":7.8,"headline":"libzypp does not reevaluate malicious rpms once downloaded","id":"CVE-2018-7685","kev_date_added":null,"published":"2018-08-31"},{"cvss_score":7.7,"headline":"lack of keypinning in libzypp could lead to repository switching","id":"CVE-2017-9269","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":4,"headline":"libzypp stores cookies world readable","id":"CVE-2019-18900","kev_date_added":null,"published":"2020-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-30","vendors":["SUSE"]},"summary":"Remote attackers can overwrite local files via malicious repository metadata in libzypp, potentially causing denial of service or privilege escalation.","url":"https://insights.sbomify.com/CVE-2026-25707/"}