# CVE-2026-25724: Claude Code Has Permission Deny Bypass Through Symbolic Links


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-4q92-rfm6-2cqx

## What is CVE-2026-25724?

CVE-2026-25724 is a low-severity vulnerability in anthropics claude-code, published on 6 Feb 2026. 

### Official description

Claude Code is an agentic coding tool. Prior to version 2.1.7, Claude Code failed to strictly enforce deny rules configured in settings.json when accessing files through symbolic links. If a user explicitly denied Claude Code access to a file (such as /etc/passwd) and Claude Code had access to a symbolic link pointing to that file, it was possible for Claude Code to read the restricted file through the symlink without triggering deny rule enforcement. This issue has been patched in version 2.1.7.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-25724?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.7 |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.7 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-25724?

Upgrade @anthropic-ai/claude-code to 2.1.7 or later.

## Is CVE-2026-25724 being exploited?

There is no known exploitation of CVE-2026-25724 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25724 and fix it if it is affected.

What it is: CVE-2026-25724 is a low-severity vulnerability in anthropics claude-code, published on 6 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-25724 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.7
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25724/ (Markdown: https://insights.sbomify.com/CVE-2026-25724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25724
- OSV: https://osv.dev/vulnerability/CVE-2026-25724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25724/
Summaries are generated and may contain mistakes; the official description above is the record.
