# CVE-2026-25725: Claude Code Has Sandbox Escape via Persistent Configuration Injection in settings.json

> Attackers can escape the sandbox and execute arbitrary code on the host by injecting persistent hooks into a missing configuration file.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** GHSA-ff64-7w26-62rf

## What is CVE-2026-25725?

CVE-2026-25725 is a high-severity code injection vulnerability in anthropics claude-code, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Prior to version 2.1.2, Claude Code's bubblewrap sandboxing mechanism failed to properly protect the .claude/settings.json configuration file when it did not exist at startup. While the parent directory was mounted as writable and .claude/settings.local.json was explicitly protected with read-only constraints, settings.json was not protected if it was missing. This allowed malicious code running inside the sandbox to create this file and inject persistent hooks (such as SessionStart commands) that would execute with host privileges when Claude Code was restarted. This issue has been patched in version 2.1.2.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-501 (Trust Boundary Violation)

## Which versions are affected by CVE-2026-25725?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.2 |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.2 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-25725?

Upgrade @anthropic-ai/claude-code to 2.1.2 or later.

## Is CVE-2026-25725 being exploited?

There is no known exploitation of CVE-2026-25725 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25725 and fix it if it is affected.

What it is: CVE-2026-25725 is a high-severity code injection vulnerability in anthropics claude-code, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25725 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.2
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25725/ (Markdown: https://insights.sbomify.com/CVE-2026-25725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25725
- OSV: https://osv.dev/vulnerability/CVE-2026-25725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25725/
Summaries are generated and may contain mistakes; the official description above is the record.
