# CVE-2026-25726: Cloudreve is vulnerable to Account Takeover via Weak Cryptographic Token Generation (Insecure PRNG Seeding)

> Attackers can predict weakly generated secrets to forge JWTs, enabling full account takeover and privilege escalation in Cloudreve.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026
- **Updated:** 4 Apr 2026
- **Also known as:** GHSA-f8xp-wvcx-p6f4, GO-2026-5350

## What is CVE-2026-25726?

CVE-2026-25726 is a high-severity vulnerability in cloudreve, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloudreve is a self-hosted file management and sharing system. Prior to version 4.13.0, the application uses the weak pseudo-random number generator math/rand seeded with time.Now().UnixNano() to generate critical security secrets, including the secret_key, and hash_id_salt. These secrets are generated upon first startup and persisted in the database. An attacker can exploit this by obtaining the administrator's account creation time (via public API endpoints) to narrow the search window for the PRNG seed, and use known hashid to validate the seed. By brute-forcing the seed (demonstrated to take <3 hours on general consumer PC), an attacker can predict the secret_key. This allows them to forge valid JSON Web Tokens (JWTs) for any user, including administrators, leading to full account takeover and privilege escalation. This issue has been patched in version 4.13.0.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2026-25726?

5 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v4, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260205113604-ec9fdd33bc54 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260205113604-ec9fdd33bc54 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260205113604-ec9fdd33bc54 |
| `github.com/cloudreve/Cloudreve` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions | None |

Products: Cloudreve Cloudreve.

## How do I fix CVE-2026-25726?

Upgrade github.com/cloudreve/Cloudreve/v4 to 4.0.0-20260205113604-ec9fdd33bc54 or later.

## Is CVE-2026-25726 being exploited?

There is no known exploitation of CVE-2026-25726 in the wild and no public exploit code.

## Other vulnerabilities in cloudreve

- [CVE-2022-32167](https://insights.sbomify.com/CVE-2022-32167/): Cloudreve - Stored XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25726 and fix it if it is affected.

What it is: CVE-2026-25726 is a high-severity vulnerability in cloudreve, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25726 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260205113604-ec9fdd33bc54
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260205113604-ec9fdd33bc54
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260205113604-ec9fdd33bc54
- github.com/cloudreve/Cloudreve (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25726/ (Markdown: https://insights.sbomify.com/CVE-2026-25726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25726
- OSV: https://osv.dev/vulnerability/CVE-2026-25726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25726/
Summaries are generated and may contain mistakes; the official description above is the record.
