# CVE-2026-25732: NiceGUI's Path Traversal via Unsanitized FileUpload.name Enables Arbitrary File Write

> Attackers can write arbitrary files outside intended directories via unsanitized filenames in NiceGUI, potentially leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-9ffm-fxg3-xrhh, PYSEC-2026-95

## What is CVE-2026-25732?

CVE-2026-25732 is a high-severity path traversal vulnerability in zauberzeug nicegui, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NiceGUI is a Python-based UI framework. Prior to 3.7.0, NiceGUI's FileUpload.name property exposes client-supplied filename metadata without sanitization, enabling path traversal when developers use the pattern UPLOAD_DIR / file.name. Malicious filenames containing ../ sequences allow attackers to write files outside intended directories, with potential for remote code execution through application file overwrites in vulnerable deployment patterns. This design creates a prevalent security footgun affecting applications following common community patterns. Note: Exploitation requires application code incorporating file.name into filesystem paths without sanitization. Applications using fixed paths, generated filenames, or explicit sanitization are not affected. This vulnerability is fixed in 3.7.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-25732?

3 open source packages ship an affected version, including nicegui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nicegui` | PyPI | All versions | 3.7.0 |
| `nicegui` | PyPI | All versions | 3.7.0 |
| `nicegui` | PyPI | All versions | 3.7.0 |

Products: Zauberzeug Nicegui.

## How do I fix CVE-2026-25732?

Upgrade nicegui to 3.7.0 or later.

## Is CVE-2026-25732 being exploited?

There is no known exploitation of CVE-2026-25732 in the wild and no public exploit code.

Public exploit code:

- https://github.com/mbanyamer/CVE-2026-25732-NiceGUI-3.6.1 (github_poc): https://github.com/mbanyamer/CVE-2026-25732-NiceGUI-3.6.1
- NiceGUI 3.6.1 - Path Traversal (exploitdb)

## Other vulnerabilities in zauberzeug nicegui

- [CVE-2025-66645](https://insights.sbomify.com/CVE-2025-66645/): NiceGUI Path Traversal Vulnerability in app.add_media_files() Allows Arbitrary File Reading (high 7.5)
- [CVE-2026-21873](https://insights.sbomify.com/CVE-2026-21873/): Zero-click XSS in all NiceGUI apps which uses `ui.sub_pages` (high 7.2)
- [CVE-2026-33332](https://insights.sbomify.com/CVE-2026-33332/): NiceGUI's unvalidated chunk size parameter in media routes can cause memory exhaustion (medium 6.9)
- [CVE-2026-27156](https://insights.sbomify.com/CVE-2026-27156/): NiceGUI has XSS via Code Injection (medium 6.1)
- [CVE-2026-25516](https://insights.sbomify.com/CVE-2026-25516/): NiceGUI's XSS vulnerability in ui.markdown() allows arbitrary JavaScript execution through unsanitized HTML content (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25732 and fix it if it is affected.

What it is: CVE-2026-25732 is a high-severity path traversal vulnerability in zauberzeug nicegui, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25732 in the wild and no public exploit code.

Affected packages and fixed versions:
- nicegui (PyPI): affected all versions; fixed in 3.7.0
- nicegui (PyPI): affected all versions; fixed in 3.7.0
- nicegui (PyPI): affected all versions; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25732/ (Markdown: https://insights.sbomify.com/CVE-2026-25732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25732
- OSV: https://osv.dev/vulnerability/CVE-2026-25732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25732/
Summaries are generated and may contain mistakes; the official description above is the record.
