CVE-2026-25736 Rucio WebUI has a Stored Cross-site Scripting (XSS) Vulnerability in its Custom RSE Attribute

Medium 6.1 Published Updated

Attackers can inject malicious scripts into Rucio WebUI via custom RSE attributes, leading to session theft or unauthorized actions for viewing users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-25736?

CVE-2026-25736 is a medium-severity cross-site scripting vulnerability in rucio, published on 25 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Rucio is a software framework that provides functionality to organize, manage, and access large volumes of scientific data using customizable policies. Versions prior to 35.8.3, 38.5.4, and 39.3.1 have a stored Cross-Site Scripting (XSS) vulnerability in the Custom RSE Attribute of the WebUI where attacker-controlled input is persisted by the backend and later rendered in the WebUI without proper output encoding. This allows arbitrary JavaScript execution in the context of the WebUI for users who view affected pages, potentially enabling session token theft or unauthorized actions. Versions 35.8.3, 38.5.4, and 39.3.1 fix the issue.

Weakness: CWE-79, CWE-1004

Which versions are affected by CVE-2026-25736?

7 open source packages ship an affected version, including rucio-webui. It affects 1 product.

PackageAffectedFixed in
rucio-webui PyPIAll versions35.8.3, 38.5.4, 39.3.1
rucio-webui PyPIAll versions35.8.3
rucio-webui PyPIAll versions35.8.3
rucio-webui PyPIFrom 36.0.0rc138.5.4
rucio-webui PyPIFrom 36.0.0rc138.5.4
rucio-webui PyPIFrom 39.0.0rc139.3.1
1 more packages
rucio-webui PyPIFrom 39.0.0rc139.3.1

Products include Cern Rucio.

How do I fix CVE-2026-25736?

Upgrade rucio-webui to a fixed version for your release line: 35.8.3, 38.5.4 or 39.3.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-25736 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25736 exists.

Sources

Also known as GHSA-fq4f-4738-rqxm, PYSEC-2026-3055.

Is CVE-2026-25736 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free