# CVE-2026-25738: Indico has Server-Side Request Forgery (SSRF) in multiple places

> Attackers can exploit SSRF in Indico to access internal services or cloud metadata, primarily affecting deployments on cloud infrastructure like AWS.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-f47c-3c5w-v7p4, PYSEC-2026-2181

## What is CVE-2026-25738?

CVE-2026-25738 is a medium-severity server-side request forgery vulnerability in indico, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Versions prior to 3.3.10 are vulnerable to server-side request forgery. Indico makes outgoing requests to user-provides URLs in various places. This is mostly intentional and part of Indico's functionality but is never intended to let users access "special" targets such as localhost or cloud metadata endpoints. Users should upgrade to version 3.3.10 to receive a patch. Those who do not have IPs that expose sensitive data without authentication (typically because they do not host Indico on AWS) are not affected. Only event organizers can access endpoints where SSRF could be used to actually see the data returned by such a request. For those who trust their event organizers, the risk is also very limited. For additional security, both before and after patching, one may also use the common proxy-related environment variables (in particular `http_proxy` and `https_proxy`) to force outgoing requests to go through a proxy that limits requests in whatever way you deem useful/necessary. These environment variables would need to be set both on the indico-uwsgi and indico-celery services.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-25738?

3 open source packages ship an affected version, including indico. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.10 |
| `indico` | PyPI | All versions | 3.3.10 |
| `indico` | PyPI | All versions | 3.3.10 |

Products: Cern Indico.

## How do I fix CVE-2026-25738?

Upgrade indico to 3.3.10 or later.

## Is CVE-2026-25738 being exploited?

There is no known exploitation of CVE-2026-25738 in the wild and no public exploit code.

## Other vulnerabilities in indico

- [CVE-2026-33046](https://insights.sbomify.com/CVE-2026-33046/): Indico discloses local files resulting in Remote Code Execution through LaTeX injection (high 7.7)
- [CVE-2021-30185](https://insights.sbomify.com/CVE-2021-30185/): Indico Tampering with links (e.g. password reset) in sent emails (high 7.5)
- [CVE-2026-28352](https://insights.sbomify.com/CVE-2026-28352/): Indico missing access check in event series management API (medium 6.5)
- [CVE-2026-25739](https://insights.sbomify.com/CVE-2026-25739/): Indico affected by Cross-Site-Scripting via material uploads (medium 5.4)
- [CVE-2023-37901](https://insights.sbomify.com/CVE-2023-37901/): Cross-Site-Scripting via confirmation prompts (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25738 and fix it if it is affected.

What it is: CVE-2026-25738 is a medium-severity server-side request forgery vulnerability in indico, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25738 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.10
- indico (PyPI): affected all versions; fixed in 3.3.10
- indico (PyPI): affected all versions; fixed in 3.3.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25738/ (Markdown: https://insights.sbomify.com/CVE-2026-25738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25738
- OSV: https://osv.dev/vulnerability/CVE-2026-25738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25738/
Summaries are generated and may contain mistakes; the official description above is the record.
