# CVE-2026-25739: Indico affected by Cross-Site-Scripting via material uploads

> Attackers can execute arbitrary scripts via malicious file uploads in Indico, potentially compromising user accounts and session data.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-jxc4-54g3-j7vp, PYSEC-2026-2182

## What is CVE-2026-25739?

CVE-2026-25739 is a medium-severity cross-site scripting vulnerability in indico, published on 19 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Versions prior to 3.3.10 are vulnerable to cross-site scripting when uploading certain file types as materials. Users should upgrade to version 3.3.10 to receive a patch. To apply the fix itself updating is sufficient, but to benefit from the strict Content Security Policy (CSP) Indico now applies by default for file downloads, update the webserver config in case one uses nginx with Indico's `STATIC_FILE_METHOD` set to `xaccelredirect`. For further directions, consult the GitHub Security advisory or Indico setup documentation. Some workarounds are available. Use the webserver config to apply a strict CSP for material download endpoints, and/or only let trustworthy users create content (including material uploads, which speakers can typically do as well) on Indico.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25739?

3 open source packages ship an affected version, including indico. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.10 |
| `indico` | PyPI | All versions | 3.3.10 |
| `indico` | PyPI | All versions | 3.3.10 |

Products: Cern Indico.

## How do I fix CVE-2026-25739?

Upgrade indico to 3.3.10 or later.

## Is CVE-2026-25739 being exploited?

There is no known exploitation of CVE-2026-25739 in the wild and no public exploit code.

## Other vulnerabilities in indico

- [CVE-2026-33046](https://insights.sbomify.com/CVE-2026-33046/): Indico discloses local files resulting in Remote Code Execution through LaTeX injection (high 7.7)
- [CVE-2021-30185](https://insights.sbomify.com/CVE-2021-30185/): Indico Tampering with links (e.g. password reset) in sent emails (high 7.5)
- [CVE-2026-25738](https://insights.sbomify.com/CVE-2026-25738/): Indico has Server-Side Request Forgery (SSRF) in multiple places (medium 6.9)
- [CVE-2026-28352](https://insights.sbomify.com/CVE-2026-28352/): Indico missing access check in event series management API (medium 6.5)
- [CVE-2023-37901](https://insights.sbomify.com/CVE-2023-37901/): Cross-Site-Scripting via confirmation prompts (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25739 and fix it if it is affected.

What it is: CVE-2026-25739 is a medium-severity cross-site scripting vulnerability in indico, published on 19 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25739 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.10
- indico (PyPI): affected all versions; fixed in 3.3.10
- indico (PyPI): affected all versions; fixed in 3.3.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25739/ (Markdown: https://insights.sbomify.com/CVE-2026-25739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25739
- OSV: https://osv.dev/vulnerability/CVE-2026-25739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25739/
Summaries are generated and may contain mistakes; the official description above is the record.
