# CVE-2026-25740: Privilege escalation to the `CAP_NET_RAW` capability via the `programs.captive-browser` NixOS module

> Enabling the captive-browser module allows any user to execute commands with CAP_NET_RAW privileges, requiring an upgrade to patched NixOS versions.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-wc3r-c66x-8xmc

## What is CVE-2026-25740?

CVE-2026-25740 is a medium-severity vulnerability in NixOS nixpkgs, published on 9 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

captive browser, a dedicated Chrome instance to log into captive portals without messing with DNS settings. In 25.05 and earlier, when programs.captive-browser is enabled, any user of the system can run arbitrary commands with the CAP_NET_RAW capability (binding to privileged ports, spoofing localhost traffic from privileged services...). This vulnerability is fixed in 25.11 and 26.05.

Weakness: CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2026-25740?


## How do I fix CVE-2026-25740?

No fix has been published for CVE-2026-25740 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25740 being exploited?

There is no known exploitation of CVE-2026-25740 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25740 and fix it if it is affected.

What it is: CVE-2026-25740 is a medium-severity vulnerability in NixOS nixpkgs, published on 9 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25740 in the wild and no public exploit code.

Affected product: NixOS nixpkgs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25740/ (Markdown: https://insights.sbomify.com/CVE-2026-25740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25740
- OSV: https://osv.dev/vulnerability/CVE-2026-25740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25740/
Summaries are generated and may contain mistakes; the official description above is the record.
