CVE-2026-25747 Apache Camel LevelDB: Deserialization of Untrusted Data in Camel LevelDB
An attacker with write access to LevelDB files can execute arbitrary code via unsafe Java deserialization in Apache Camel.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25747?
CVE-2026-25747 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 23 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component.
The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0.
Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5
Weakness: CWE-502
Which versions are affected by CVE-2026-25747?
6 open source packages ship an affected version, including org.apache.camel:camel-leveldb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-leveldb Maven | From 3.0.0 | 4.10.9 |
org.apache.camel:camel-leveldb Maven | From 3.0.0 | 4.10.9 |
org.apache.camel:camel-leveldb Maven | From 4.11.0 | 4.14.5 |
org.apache.camel:camel-leveldb Maven | From 4.11.0 | 4.14.5 |
org.apache.camel:camel-leveldb Maven | From 4.15.0 | 4.18.0 |
org.apache.camel:camel-leveldb Maven | From 4.15.0 | 4.18.0 |
Products include Apache Camel.
How do I fix CVE-2026-25747?
Upgrade org.apache.camel:camel-leveldb to a fixed version for your release line: 4.10.9, 4.14.5 or 4.18.0.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-25747 being exploited?
There is no known exploitation of CVE-2026-25747 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as GHSA-429q-mrc4-38fr.