# CVE-2026-25747: Apache Camel LevelDB: Deserialization of Untrusted Data in Camel LevelDB

> An attacker with write access to LevelDB files can execute arbitrary code via unsafe Java deserialization in Apache Camel.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-429q-mrc4-38fr

## What is CVE-2026-25747?

CVE-2026-25747 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 23 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component.

The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application.
This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0.

Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-25747?

6 open source packages ship an affected version, including org.apache.camel:camel-leveldb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-leveldb` | Maven | From 3.0.0 | 4.10.9 |
| `org.apache.camel:camel-leveldb` | Maven | From 3.0.0 | 4.10.9 |
| `org.apache.camel:camel-leveldb` | Maven | From 4.11.0 | 4.14.5 |
| `org.apache.camel:camel-leveldb` | Maven | From 4.11.0 | 4.14.5 |
| `org.apache.camel:camel-leveldb` | Maven | From 4.15.0 | 4.18.0 |
| `org.apache.camel:camel-leveldb` | Maven | From 4.15.0 | 4.18.0 |

Products: Apache Camel.

## How do I fix CVE-2026-25747?

Upgrade org.apache.camel:camel-leveldb to a fixed version for your release line: 4.10.9, 4.14.5 or 4.18.0.

## Is CVE-2026-25747 being exploited?

There is no known exploitation of CVE-2026-25747 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-25747 - Camel LevelDB Deserialization Vulnerability (github_poc): https://github.com/oscerd/CVE-2026-25747

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25747 and fix it if it is affected.

What it is: CVE-2026-25747 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 23 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25747 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-leveldb (Maven): affected from 3.0.0; fixed in 4.10.9
- org.apache.camel:camel-leveldb (Maven): affected from 3.0.0; fixed in 4.10.9
- org.apache.camel:camel-leveldb (Maven): affected from 4.11.0; fixed in 4.14.5
- org.apache.camel:camel-leveldb (Maven): affected from 4.11.0; fixed in 4.14.5
- org.apache.camel:camel-leveldb (Maven): affected from 4.15.0; fixed in 4.18.0
- org.apache.camel:camel-leveldb (Maven): affected from 4.15.0; fixed in 4.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25747/ (Markdown: https://insights.sbomify.com/CVE-2026-25747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25747
- OSV: https://osv.dev/vulnerability/CVE-2026-25747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25747/
Summaries are generated and may contain mistakes; the official description above is the record.
