CVE-2026-25749 Heap Overflow in Vim

Medium 6.6 Published Updated

A heap buffer overflow in Vim's tag file resolution allows attackers to execute arbitrary code or cause a crash via a crafted helpfile option.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-25749?

CVE-2026-25749 is a medium-severity memory corruption vulnerability in Vim Vim, published on 6 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Vim is an open source, command line text editor. Prior to version 9.1.2132, a heap buffer overflow vulnerability exists in Vim's tag file resolution logic when processing the 'helpfile' option. The vulnerability is located in the get_tagfname() function in src/tag.c. When processing help file tags, Vim copies the user-controlled 'helpfile' option value into a fixed-size heap buffer of MAXPATHL + 1 bytes (typically 4097 bytes) using an unsafe STRCPY() operation without any bounds checking. This issue has been patched in version 9.1.2132.

Weakness: CWE-122

Which versions are affected by CVE-2026-25749?

It affects 2 products.

Linux distribution packages (27)
vim-data AlmaLinux:10All versions2:9.1.083-6.el10_1.1
vim-filesystem AlmaLinux:10All versions2:9.1.083-6.el10_1.1
vim-X11 AlmaLinux:8All versions2:8.0.1763-22.el8_10
vim-common AlmaLinux:8All versions2:8.0.1763-22.el8_10
vim-enhanced AlmaLinux:8All versions2:8.0.1763-22.el8_10
vim-filesystem AlmaLinux:8All versions2:8.0.1763-22.el8_10
vim-minimal AlmaLinux:8All versions2:8.0.1763-22.el8_10
vim-X11 AlmaLinux:9All versions2:8.2.2637-23.el9_7.1
vim-common AlmaLinux:9All versions2:8.2.2637-23.el9_7.1
vim-enhanced AlmaLinux:9All versions2:8.2.2637-23.el9_7.1
vim-filesystem AlmaLinux:9All versions2:8.2.2637-23.el9_7.1
vim-minimal AlmaLinux:9All versions2:8.2.2637-23.el9_7.1
vim Red Hat:enterprise_linux:10.1All versions2:9.1.083-6.el10_1.1
vim-X11 Red Hat:enterprise_linux:10.1All versions2:9.1.083-6.el10_1.1
vim-enhanced Red Hat:enterprise_linux:10.1All versions2:9.1.083-6.el10_1.1
vim-minimal Red Hat:enterprise_linux:10.1All versions2:9.1.083-6.el10_1.1
vim-X11 Red Hat:enterprise_linux:8::appstreamAll versions2:8.0.1763-22.el8_10
vim-enhanced Red Hat:enterprise_linux:8::appstreamAll versions2:8.0.1763-22.el8_10
vim Red Hat:enterprise_linux:8::baseosAll versions2:8.0.1763-22.el8_10
vim-minimal Red Hat:enterprise_linux:8::baseosAll versions2:8.0.1763-22.el8_10
vim-X11 Red Hat:enterprise_linux:9::appstreamAll versions2:8.2.2637-23.el9_7.1
vim-enhanced Red Hat:enterprise_linux:9::appstreamAll versions2:8.2.2637-23.el9_7.1
vim Red Hat:enterprise_linux:9::baseosAll versions2:8.2.2637-23.el9_7.1
vim-minimal Red Hat:enterprise_linux:9::baseosAll versions2:8.2.2637-23.el9_7.1
vim Rocky Linux:10All versions2:9.1.083-6.el10_1.1
vim Rocky Linux:8All versions2:8.0.1763-22.el8_10
vim Rocky Linux:9All versions2:8.2.2637-23.el9_7.1

Products include Neovim Neovim, Vim Vim.

How do I fix CVE-2026-25749?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-25749 being exploited?

There is no known exploitation of CVE-2026-25749 in the wild and no public exploit code.

All Vim Vim vulnerabilities

Sources

Also known as ALPINE-CVE-2026-25749, ALSA-2026:4442, ALSA-2026:4715, ALSA-2026:5602, AZL-76764, AZL-77411 and 15 more.

Is CVE-2026-25749 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free