# CVE-2026-2575: Keycloak: keycloak: denial of service due to excessive samlrequest decompression

> An unauthenticated attacker can cause a denial of service in Keycloak by sending a highly compressed SAMLRequest that triggers an OutOfMemoryError.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-keycloak-2026-2575, ECHO-12de-2dca-d7dc, GHSA-xv6h-r36f-3gp5, MINI-7f5h-wq4f-m4j2, MINI-v7vj-pgq3-jxp9

## What is CVE-2026-2575?

CVE-2026-2575 is a medium-severity denial of service vulnerability in Redhat Build of Keycloak, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Keycloak. An unauthenticated remote attacker can trigger an application level Denial of Service (DoS) by sending a highly compressed SAMLRequest through the SAML Redirect Binding. The server fails to enforce size limits during DEFLATE decompression, leading to an OutOfMemoryError (OOM) and subsequent process termination. This vulnerability allows an attacker to disrupt the availability of the service.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-2575?

7 open source packages ship an affected version, including org.keycloak:keycloak-saml-adapter-core, keycloak and org.keycloak:keycloak-saml-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-saml-adapter-core` | Maven | All versions | 26.5.4 |
| `org.keycloak:keycloak-saml-adapter-core` | Maven | All versions | 26.5.4 |
| `keycloak` | Bitnami | From 26.4.0 | 26.4.10 |
| `org.keycloak:keycloak-saml-core` | Maven | All versions | 26.5.4 |
| `org.keycloak:keycloak-saml-core` | Maven | All versions | 26.5.4 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.4 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.4 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-2575?

Upgrade org.keycloak:keycloak-saml-adapter-core to 26.5.4 or later.

## Is CVE-2026-2575 being exploited?

There is no known exploitation of CVE-2026-2575 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2575 and fix it if it is affected.

What it is: CVE-2026-2575 is a medium-severity denial of service vulnerability in Redhat Build of Keycloak, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2575 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-saml-adapter-core (Maven): affected all versions; fixed in 26.5.4
- org.keycloak:keycloak-saml-adapter-core (Maven): affected all versions; fixed in 26.5.4
- keycloak (Bitnami): affected from 26.4.0; fixed in 26.4.10
- org.keycloak:keycloak-saml-core (Maven): affected all versions; fixed in 26.5.4
- org.keycloak:keycloak-saml-core (Maven): affected all versions; fixed in 26.5.4
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.4
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2575/ (Markdown: https://insights.sbomify.com/CVE-2026-2575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2575
- OSV: https://osv.dev/vulnerability/CVE-2026-2575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2575/
Summaries are generated and may contain mistakes; the official description above is the record.
