# CVE-2026-25757: Unauthenticated Spree Commerce users can view completed guest orders by Order ID

> Unauthenticated attackers can view completed guest orders and access PII by guessing Order IDs in Spree Commerce.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-p6pv-q7rc-g4h9

## What is CVE-2026-25757?

CVE-2026-25757 is a high-severity missing authorization vulnerability in spree, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spree is an open source e-commerce solution built with Ruby on Rails. Prior to versions 5.0.8, 5.1.10, 5.2.7, and 5.3.2, unauthenticated users can view completed guest orders by Order ID. This issue may lead to disclosure of PII of guest users (including names, addresses and phone numbers). This issue has been patched in versions 5.0.8, 5.1.10, 5.2.7, and 5.3.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-25757?

8 open source packages ship an affected version, including spree_storefront. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spree_storefront` | RubyGems | All versions | 5.0.8 |
| `spree_storefront` | RubyGems | All versions | 5.0.8 |
| `spree_storefront` | RubyGems | From 5.1.0 | 5.1.10 |
| `spree_storefront` | RubyGems | From 5.1.0 | 5.1.10 |
| `spree_storefront` | RubyGems | From 5.2.0 | 5.2.7 |
| `spree_storefront` | RubyGems | From 5.2.0 | 5.2.7 |
| `spree_storefront` | RubyGems | From 5.3.0 | 5.3.2 |
| `spree_storefront` | RubyGems | From 5.3.0 | 5.3.2 |

Products: Spreecommerce Spree.

## How do I fix CVE-2026-25757?

Upgrade spree_storefront to a fixed version for your release line: 5.0.8, 5.1.10, 5.2.7 or 5.3.2.

## Is CVE-2026-25757 being exploited?

There is no known exploitation of CVE-2026-25757 in the wild and no public exploit code.

## Other vulnerabilities in spree

- [CVE-2011-10019](https://insights.sbomify.com/CVE-2011-10019/): Spreecommerce < 0.60.2 Search Parameter RCE (critical 10.0)
- [CVE-2011-10026](https://insights.sbomify.com/CVE-2011-10026/): Spreecommerce < 0.50.x API RCE (critical 9.3)
- [CVE-2026-25758](https://insights.sbomify.com/CVE-2026-25758/): Spree allows unauthenticated users can access all guest addresses (high 7.7)
- [CVE-2020-26223](https://insights.sbomify.com/CVE-2020-26223/): Authorization bypass in Spree (high 7.7)
- [CVE-2026-22589](https://insights.sbomify.com/CVE-2026-22589/): Spree API has Unauthenticated IDOR - Guest Address (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25757 and fix it if it is affected.

What it is: CVE-2026-25757 is a high-severity missing authorization vulnerability in spree, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25757 in the wild and no public exploit code.

Affected packages and fixed versions:
- spree_storefront (RubyGems): affected all versions; fixed in 5.0.8
- spree_storefront (RubyGems): affected all versions; fixed in 5.0.8
- spree_storefront (RubyGems): affected from 5.1.0; fixed in 5.1.10
- spree_storefront (RubyGems): affected from 5.1.0; fixed in 5.1.10
- spree_storefront (RubyGems): affected from 5.2.0; fixed in 5.2.7
- spree_storefront (RubyGems): affected from 5.2.0; fixed in 5.2.7
- spree_storefront (RubyGems): affected from 5.3.0; fixed in 5.3.2
- spree_storefront (RubyGems): affected from 5.3.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25757/ (Markdown: https://insights.sbomify.com/CVE-2026-25757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25757
- OSV: https://osv.dev/vulnerability/CVE-2026-25757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25757/
Summaries are generated and may contain mistakes; the official description above is the record.
