CVE-2026-25759 Statmatic affected by privilege escalation via stored cross-site scripting

High 8.7 Published Updated

Authenticated users can inject scripts into content titles to escalate privileges and create super admin accounts in Statamic CMS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-25759?

CVE-2026-25759 is a high-severity cross-site scripting vulnerability in statamic cms, published on 11 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Statmatic is a Laravel and Git powered content management system (CMS). From 6.0.0 to before 6.2.3, a stored XSS vulnerability in content titles allows authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. Malicious user must have an account with control panel access and content creation permissions. This vulnerability can be exploited to allow super admin accounts to be created. This has been fixed in 6.2.3.

Weakness: CWE-79

Which versions are affected by CVE-2026-25759?

2 open source packages ship an affected version, including statamic/cms. It affects 1 product.

PackageAffectedFixed in
statamic/cms PackagistFrom 6.0.06.2.3
statamic/cms PackagistFrom 6.0.06.2.3

Products include Statamic Statamic.

How do I fix CVE-2026-25759?

Upgrade statamic/cms to 6.2.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-25759 being exploited?

There is no known exploitation of CVE-2026-25759 in the wild and no public exploit code.

Sources

Also known as GHSA-ff9r-ww9c-43x8.

Is CVE-2026-25759 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free