{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-25767 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-25767 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-25767 is a high-severity missing authorization vulnerability in cloudamqp lavinmq, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-25767 and fix it if it is affected.\n\nWhat it is: CVE-2026-25767 is a high-severity missing authorization vulnerability in cloudamqp lavinmq, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-25767 in the wild and no public exploit code.\n\nAffected product: cloudamqp lavinmq. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25767/ (Markdown: https://insights.sbomify.com/CVE-2026-25767/index.md)","id":"CVE-2026-25767","markdown":"https://insights.sbomify.com/CVE-2026-25767/index.md","name":"CVE-2026-25767","record":{"aliases":["GHSA-wh37-6vrr-r9wg"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Message queue server","requires_auth":"low_privilege","summary":"Authenticated Policymaker users can bypass access controls to read or publish messages in unauthorized vhosts via incomplete shovel configuration validation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lavinmq","vendor":"84codes"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"LavinMQ is a high-performance message queue \u0026 streaming server. Before 2.6.8, an authenticated user, with the “Policymaker” tag, could create shovels bypassing access controls. an authenticated user with the \"Policymaker\" management tag could exploit it to read messages from vhosts they are not authorized to access or publish messages to vhosts they are not authorized to access. This vulnerability is fixed in 2.6.8.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"LavinMQ has incomplete shovel configuration validation","id":"CVE-2026-25767","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"LavinMQ is missing vhost access control","id":"CVE-2026-25768"},"packages":[],"prev":{"headline":"Echo has a Windows path traversal via backslash in middleware.Static default filesystem","id":"CVE-2026-25766"},"products":["lavinmq"],"published":"2026-02-12","related":[{"cvss_score":7.1,"headline":"LavinMQ is missing vhost access control","id":"CVE-2026-25768","kev_date_added":null,"published":"2026-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-12","vendors":["cloudamqp"]},"summary":"Authenticated Policymaker users can bypass access controls to read or publish messages in unauthorized vhosts via incomplete shovel configuration validation.","url":"https://insights.sbomify.com/CVE-2026-25767/"}