# CVE-2026-25767: LavinMQ has incomplete shovel configuration validation

> Authenticated Policymaker users can bypass access controls to read or publish messages in unauthorized vhosts via incomplete shovel configuration validation.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** GHSA-wh37-6vrr-r9wg

## What is CVE-2026-25767?

CVE-2026-25767 is a high-severity missing authorization vulnerability in cloudamqp lavinmq, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LavinMQ is a high-performance message queue & streaming server. Before 2.6.8, an authenticated user, with the “Policymaker” tag, could create shovels bypassing access controls. an authenticated user with the "Policymaker" management tag could exploit it to read messages from vhosts they are not authorized to access or publish messages to vhosts they are not authorized to access. This vulnerability is fixed in 2.6.8.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-25767?

It affects 1 product.


Products: 84codes Lavinmq.

## How do I fix CVE-2026-25767?

No fix has been published for CVE-2026-25767 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25767 being exploited?

There is no known exploitation of CVE-2026-25767 in the wild and no public exploit code.

## Other vulnerabilities in cloudamqp lavinmq

- [CVE-2026-25768](https://insights.sbomify.com/CVE-2026-25768/): LavinMQ is missing vhost access control (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25767 and fix it if it is affected.

What it is: CVE-2026-25767 is a high-severity missing authorization vulnerability in cloudamqp lavinmq, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25767 in the wild and no public exploit code.

Affected product: cloudamqp lavinmq. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25767/ (Markdown: https://insights.sbomify.com/CVE-2026-25767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25767
- OSV: https://osv.dev/vulnerability/CVE-2026-25767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25767/
Summaries are generated and may contain mistakes; the official description above is the record.
