CVE-2026-2578 Information Disclosure via WebSocket Event When Deleting Unrevealed Burn on Read Posts
Channel members can access unrevealed burn-on-read message contents via WebSocket events during deletion in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2578?
CVE-2026-2578 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.3.x <= 11.3.0 fail to preserve the redacted state of burn-on-read posts during deletion which allows channel members to access unrevealed burn-on-read message contents via the WebSocket post deletion event.. Mattermost Advisory ID: MMSA-2026-00579
Weakness: CWE-201
Which versions are affected by CVE-2026-2578?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260127062706-c6b205f0d770 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260127062706-c6b205f0d770 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1+incompatible | 10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
8 more packages
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260127062706-c6b205f0d770 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260127062706-c6b205f0d770 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260127062706-c6b205f0d770 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-2578?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20260127062706-c6b205f0d770, 10.11.11, 10.11.11+incompatible or 11.2.3+incompatible.
Is CVE-2026-2578 being exploited?
There is no known exploitation of CVE-2026-2578 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-3rhr-jr63-hwq5, GO-2026-4734.