CVE-2026-25783 Denial of service via malformed User-Agent header in getBrowserVersion
An authenticated attacker can cause a service panic and denial of service by sending a malformed User-Agent header to the Mattermost server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25783?
CVE-2026-25783 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly validate User-Agent header tokens which allows an authenticated attacker to cause a request panic via a specially crafted User-Agent header. Mattermost Advisory ID: MMSA-2026-00586
Weakness: CWE-1287
Which versions are affected by CVE-2026-25783?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260129181235-1346cf529aef |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260129181235-1346cf529aef |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1+incompatible | 10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
8 more packages
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260129181235-1346cf529aef |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260129181235-1346cf529aef |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260129181235-1346cf529aef |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-25783?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20260129181235-1346cf529aef, 10.11.11, 10.11.11+incompatible or 11.2.3+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-25783 being exploited?
There is no known exploitation of CVE-2026-25783 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-2v3w-6g35-5f9v, GO-2026-4725.