# CVE-2026-25793: Nebula Has Possible Blocklist Bypass via ECDSA Signature Malleability

> Attackers can bypass certificate blocklists in Nebula by exploiting ECDSA signature malleability when using non-default P256 certificates.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** CLEANSTART-2026-FB73701, CLEANSTART-2026-XI53576, CLEANSTART-2026-ZG76614, GHSA-69x3-g4r3-p962, GO-2026-4458, MINI-8qgr-99vw-p8xr

## What is CVE-2026-25793?

CVE-2026-25793 is a high-severity vulnerability in slackhq nebula, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nebula is a scalable overlay networking tool. In versions from 1.7.0 to 1.10.2, when using P256 certificates (which is not the default configuration), it is possible to evade a blocklist entry created against the fingerprint of a certificate by using ECDSA Signature Malleability to use a copy of the certificate with a different fingerprint. This issue has been patched in version 1.10.3.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-25793?

3 open source packages ship an affected version, including github.com/slackhq/nebula. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/slackhq/nebula` | Go | From 1.7.0 | 1.10.3 |
| `github.com/slackhq/nebula` | Go | From 1.7.0 | 1.10.3 |
| `github.com/slackhq/nebula` | Go | From 1.7.0 | 1.10.3 |

Products: Slack Nebula.

## How do I fix CVE-2026-25793?

Upgrade github.com/slackhq/nebula to 1.10.3 or later.

## Is CVE-2026-25793 being exploited?

There is no known exploitation of CVE-2026-25793 in the wild and no public exploit code.

## Other vulnerabilities in slackhq nebula

- [CVE-2020-11498](https://insights.sbomify.com/CVE-2020-11498/): Path traversal in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25793 and fix it if it is affected.

What it is: CVE-2026-25793 is a high-severity vulnerability in slackhq nebula, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25793 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/slackhq/nebula (Go): affected from 1.7.0; fixed in 1.10.3
- github.com/slackhq/nebula (Go): affected from 1.7.0; fixed in 1.10.3
- github.com/slackhq/nebula (Go): affected from 1.7.0; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25793/ (Markdown: https://insights.sbomify.com/CVE-2026-25793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25793
- OSV: https://osv.dev/vulnerability/CVE-2026-25793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25793/
Summaries are generated and may contain mistakes; the official description above is the record.
