# CVE-2026-25800: quinn-proto has remote memory exhaustion from unbounded out-of-order stream reassembly

> Remote attackers can cause memory exhaustion in applications using the quinn-proto library by sending fragmented QUIC stream data with gaps.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2026
- **Updated:** 23 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-25800, GHSA-4w2j-m93h-cj5j, GHSA-qfwj-vfxf-92j2, MINI-4jv8-9w8q-jqqc, MINI-4xpc-vv54-h77c, MINI-7534-x6x6-w9v6, MINI-7r8w-793h-pfj5, MINI-fcq4-rjvw-vgm5, MINI-fpwj-m5pm-f6vh, MINI-j9pc-627p-wh5q, MINI-px9r-6g8c-32f3, MINI-r38x-v7j7-8q99, MINI-r8wp-qphg-v6m7, MINI-vf4g-g954-w9wj, RUSTSEC-2026-0185, RUSTSEC-2026-0341, UBUNTU-CVE-2026-25800, openSUSE-SU-2026:11635-1, openSUSE-SU-2026:11662-1, openSUSE-SU-2026:21870-1

## What is CVE-2026-25800?

CVE-2026-25800 is a high-severity denial of service vulnerability in quinn-rs quinn, published on 23 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Quinn is a pure-Rust, async-compatible implementation of the IETF QUIC transport protocol. Starting in version 0.1.0 and prior to version 0.11.15, the `Assembler` component that assembles unordered stream fragments into consecutive chunks of the stream incurs some overhead for non-contiguous fragments. Readers that read from a `RecvStream` in order (through an `AsyncRead` impl for example) will be sensitive to peers that send fragments while leaving out early parts of the stream, and in particular, fragments with many gaps (because these cannot be defragmented). In such a scenario, the receiving connection suffers from high buffer overhead, enabling memory exhaustion. Version 0.11.15 fixes the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-25800?

4 open source packages ship an affected version, including quinn-proto.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quinn-proto` | crates.io | From 0.0.0-0 | 0.11.15 |
| `quinn-proto` | crates.io | From 0.1.0 | 0.11.15 |
| `quinn-proto` | crates.io | From 0.1.0 | 0.11.15 |
| `quinn-proto` | crates.io | From 0.11.15 | 0.11.17 |
| `openai-codex` | openSUSE:Leap 16.0 | All versions | 0.154.0-bp160.1.1 |
| `openai-codex` | openSUSE:Tumbleweed | All versions | 0.152.0-1.1 |
| `python-uv` | openSUSE:Tumbleweed | All versions | 0.12.7-1.1 |

## How do I fix CVE-2026-25800?

Upgrade quinn-proto to a fixed version for your release line: 0.11.15 or 0.11.17.

## Is CVE-2026-25800 being exploited?

There is no known exploitation of CVE-2026-25800 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25800 and fix it if it is affected.

What it is: CVE-2026-25800 is a high-severity denial of service vulnerability in quinn-rs quinn, published on 23 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25800 in the wild and no public exploit code.

Affected packages and fixed versions:
- quinn-proto (crates.io): affected from 0.0.0-0; fixed in 0.11.15
- quinn-proto (crates.io): affected from 0.1.0; fixed in 0.11.15
- quinn-proto (crates.io): affected from 0.1.0; fixed in 0.11.15
- quinn-proto (crates.io): affected from 0.11.15; fixed in 0.11.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25800/ (Markdown: https://insights.sbomify.com/CVE-2026-25800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25800
- OSV: https://osv.dev/vulnerability/CVE-2026-25800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25800/
Summaries are generated and may contain mistakes; the official description above is the record.
