# CVE-2026-25803: 3DP-MANAGER Uses Hard-coded Credentials

> Attackers can gain full administrative control of 3DP-MANAGER by using known default credentials, allowing them to manage VPN tunnels and system settings.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-5x57-h7cw-9jmw

## What is CVE-2026-25803?

CVE-2026-25803 is a critical vulnerability in denpiligrim 3dp-manager, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

3DP-MANAGER is an inbound generator for 3x-ui. In version 2.0.1 and prior, the application automatically creates an administrative account with known default credentials (admin/admin) upon the first initialization. Attackers with network access to the application's login interface can gain full administrative control, managing VPN tunnels and system settings. This issue will be patched in version 2.0.2.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-25803?

It affects 1 product.


Products: Denpiligrim 3dp-Manager.

## How do I fix CVE-2026-25803?

No fix has been published for CVE-2026-25803 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25803 being exploited?

There is no known exploitation of CVE-2026-25803 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25803 and fix it if it is affected.

What it is: CVE-2026-25803 is a critical vulnerability in denpiligrim 3dp-manager, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25803 in the wild and no public exploit code.

Affected product: denpiligrim 3dp-manager. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25803/ (Markdown: https://insights.sbomify.com/CVE-2026-25803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25803
- OSV: https://osv.dev/vulnerability/CVE-2026-25803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25803/
Summaries are generated and may contain mistakes; the official description above is the record.
