# CVE-2026-25804: Antrea has invalid enforcement order for network policy rules caused by integer overflow

> An integer overflow in Antrea's network policy priority calculation can lead to incorrect traffic enforcement, bypassing intended security controls.

- **Severity:** High 8.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-86x4-wp9f-wrr9, GO-2026-4461

## What is CVE-2026-25804?

CVE-2026-25804 is a high-severity vulnerability in antrea-io antrea, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Antrea is a Kubernetes networking solution intended to be Kubernetes native. Prior to versions 2.3.2 and 2.4.3, Antrea's network policy priority assignment system has a uint16 arithmetic overflow bug that causes incorrect OpenFlow priority calculations when handling a large numbers of policies with various priority values. This results in potentially incorrect traffic enforcement. This issue has been patched in versions 2.4.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-25804?

5 open source packages ship an affected version, including antrea.io/antrea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `antrea.io/antrea` | Go | All versions | None |
| `antrea.io/antrea` | Go | All versions | 2.3.2 |
| `antrea.io/antrea` | Go | All versions | 2.3.2 |
| `antrea.io/antrea` | Go | From 2.4.0 | 2.4.3 |
| `antrea.io/antrea` | Go | From 2.4.0 | 2.4.3 |

Products: Linuxfoundation Antrea.

## How do I fix CVE-2026-25804?

Upgrade antrea.io/antrea to a fixed version for your release line: 2.3.2 or 2.4.3.

## Is CVE-2026-25804 being exploited?

There is no known exploitation of CVE-2026-25804 in the wild and no public exploit code.

## Other vulnerabilities in antrea-io antrea

- [CVE-2026-34992](https://insights.sbomify.com/CVE-2026-34992/): Missing Encryption of Sensitive Data in antrea.io/antrea (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25804 and fix it if it is affected.

What it is: CVE-2026-25804 is a high-severity vulnerability in antrea-io antrea, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25804 in the wild and no public exploit code.

Affected packages and fixed versions:
- antrea.io/antrea (Go): affected all versions; no fix listed
- antrea.io/antrea (Go): affected all versions; fixed in 2.3.2
- antrea.io/antrea (Go): affected all versions; fixed in 2.3.2
- antrea.io/antrea (Go): affected from 2.4.0; fixed in 2.4.3
- antrea.io/antrea (Go): affected from 2.4.0; fixed in 2.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25804/ (Markdown: https://insights.sbomify.com/CVE-2026-25804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25804
- OSV: https://osv.dev/vulnerability/CVE-2026-25804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25804/
Summaries are generated and may contain mistakes; the official description above is the record.
