# CVE-2026-25807: Unauthenticated Remote Code Execution via P2P Sharing in ZAI-Shell

> Remote attackers can execute arbitrary system commands via unauthenticated P2P sharing if the user approves the action without review.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-6pjj-r955-34rr

## What is CVE-2026-25807?

CVE-2026-25807 is a high-severity command injection vulnerability in TaklaXBR zai-shell, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ZAI Shell is an autonomous SysOps agent designed to navigate, repair, and secure complex environments. Prior to 9.0.3, the P2P terminal sharing feature (share start) opens a TCP socket on port 5757 without any authentication mechanism. Any remote attacker can connect to this port using a simple socket script. An attacker who connects to a ZAI-Shell P2P session running in --no-ai mode can send arbitrary system commands. If the host user approves the command without reviewing its contents, the command executes directly with the user's privileges, bypassing all Sentinel safety checks. This vulnerability is fixed in 9.0.3.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-25807?

It affects 1 product.


Products: Taklaxbr Zai Shell.

## How do I fix CVE-2026-25807?

No fix has been published for CVE-2026-25807 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25807 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25807 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25807 and fix it if it is affected.

What it is: CVE-2026-25807 is a high-severity command injection vulnerability in TaklaXBR zai-shell, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25807 exists.

Affected product: TaklaXBR zai-shell. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25807/ (Markdown: https://insights.sbomify.com/CVE-2026-25807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25807
- OSV: https://osv.dev/vulnerability/CVE-2026-25807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25807/
Summaries are generated and may contain mistakes; the official description above is the record.
