CVE-2026-2581 Undici has Unbounded Memory Consumption in its DeduplicationHandler via Response Buffering that leads to DoS
An attacker can cause denial of service via memory exhaustion in Undici's deduplication interceptor when enabled, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2581?
CVE-2026-2581 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
This is an uncontrolled resource consumption vulnerability (CWE-400) that can lead to Denial of Service (DoS).
In vulnerable Undici versions, when interceptors.deduplicate() is enabled, response data for deduplicated requests could be accumulated in memory for downstream handlers. An attacker-controlled or untrusted upstream endpoint can exploit this with large/chunked responses and concurrent identical requests, causing high memory usage and potential OOM process termination.
Impacted users are applications that use Undici’s deduplication interceptor against endpoints that may produce large or long-lived response bodies.
PatchesThe issue has been patched by changing deduplication behavior to stream response chunks to downstream handlers as they arrive (instead of full-body accumulation), and by preventing late deduplication when body streaming has already started.
Users should upgrade to the first official Undici (and Node.js, where applicable) releases that include this patch.
Weakness: CWE-770
Which versions are affected by CVE-2026-2581?
2 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.17.0 | 7.24.0 |
undici npm | From 7.17.0 | 7.24.0 |
Products include Nodejs Undici.
How do I fix CVE-2026-2581?
Upgrade undici to 7.24.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-2581 being exploited?
There is no known exploitation of CVE-2026-2581 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as BELL-CVE-2026-2581, CLEANSTART-2026-DD51725, CLEANSTART-2026-JE55781, DEBIAN-CVE-2026-2581, GHSA-phc3-fgpg-7m6h, MINI-cpgq-7mgg-j4vp and 3 more.