# CVE-2026-2581: Undici has Unbounded Memory Consumption in its DeduplicationHandler via Response Buffering that leads to DoS

> An attacker can cause denial of service via memory exhaustion in Undici's deduplication interceptor when enabled, requiring an upgrade to patched versions.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2026
- **Updated:** 13 Mar 2026
- **Also known as:** BELL-CVE-2026-2581, CLEANSTART-2026-DD51725, CLEANSTART-2026-JE55781, DEBIAN-CVE-2026-2581, GHSA-phc3-fgpg-7m6h, MINI-cpgq-7mgg-j4vp, MINI-gp5q-f64j-5cgr, MINI-w9v4-2prx-cq3h, UBUNTU-CVE-2026-2581

## What is CVE-2026-2581?

CVE-2026-2581 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This is an uncontrolled resource consumption vulnerability (CWE-400) that can lead to Denial of Service (DoS).

In vulnerable Undici versions, when interceptors.deduplicate() is enabled, response data for deduplicated requests could be accumulated in memory for downstream handlers. An attacker-controlled or untrusted upstream endpoint can exploit this with large/chunked responses and concurrent identical requests, causing high memory usage and potential OOM process termination.

Impacted users are applications that use Undici’s deduplication interceptor against endpoints that may produce large or long-lived response bodies.

PatchesThe issue has been patched by changing deduplication behavior to stream response chunks to downstream handlers as they arrive (instead of full-body accumulation), and by preventing late deduplication when body streaming has already started.

Users should upgrade to the first official Undici (and Node.js, where applicable) releases that include this patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-2581?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.17.0 | 7.24.0 |
| `undici` | npm | From 7.17.0 | 7.24.0 |

Products: Nodejs Undici.

## How do I fix CVE-2026-2581?

Upgrade undici to 7.24.0 or later.

## Is CVE-2026-2581 being exploited?

There is no known exploitation of CVE-2026-2581 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2581 and fix it if it is affected.

What it is: CVE-2026-2581 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2581 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.17.0; fixed in 7.24.0
- undici (npm): affected from 7.17.0; fixed in 7.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2581/ (Markdown: https://insights.sbomify.com/CVE-2026-2581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2581
- OSV: https://osv.dev/vulnerability/CVE-2026-2581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2581/
Summaries are generated and may contain mistakes; the official description above is the record.
