# CVE-2026-2587: GlassFish's gadget handler is vulnerable to RCE

> Remote attackers can execute arbitrary code via unsanitized Expression Language injection in GlassFish XML processing, compromising the host.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 29 Jun 2026
- **Also known as:** GHSA-29wv-cv7p-xjc2

## What is CVE-2026-2587?

CVE-2026-2587 is a critical code injection vulnerability in Eclipse Glassfish, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A critical Remote Code Execution (RCE) vulnerability was identified in the server-side template rendering mechanism used by the Glassfish gadget handler. The application processes .xml files and evaluates user-supplied values within a context where Expression Language (EL) “expressions” are processed without proper sanitization or escaping. By injecting expressions such as #{7*7}, the server returns 49, confirming server-side EL evaluation. This issue allows a remote attacker to fully compromise the underlying host, enabling capabilities as reading/modifying data, executing arbitrary commands, persistence, and lateral movement. This issue affects Eclipse GlassFish: from 8.0.0 to 8.0.1, fixed in 8.0.2; 7.1.0, fixed in 7.1.1; from 7.0.0 to 7.0.25, fixed in 7.0.26. Impact on versions from 5.1.0 to 6.2.5 is unknown.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2026-2587?

4 open source packages ship an affected version, including org.glassfish.jsftemplating:jsftemplating and org.glassfish.main.admingui:admingui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.glassfish.jsftemplating:jsftemplating` | Maven | All versions | 4.2.0 |
| `org.glassfish.jsftemplating:jsftemplating` | Maven | All versions | 4.2.0 |
| `org.glassfish.main.admingui:admingui` | Maven | All versions | 8.0.2 |
| `org.glassfish.main.admingui:admingui` | Maven | All versions | 8.0.2 |

Products: Eclipse Glassfish.

## How do I fix CVE-2026-2587?

Upgrade org.glassfish.jsftemplating:jsftemplating to 4.2.0 or later.

## Is CVE-2026-2587 being exploited?

There is no known exploitation of CVE-2026-2587 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-2587 PoC validator for Eclipse GlassFish EL Injection RCE in the admin console gadget.jsf handler. Safe authenticated vulnerability scanner for authorized testing. (github_poc): https://github.com/Bhanunamikaze/CVE-2026-2587-Exploit-POC

## Other vulnerabilities in Eclipse Glassfish

- [CVE-2026-12605](https://insights.sbomify.com/CVE-2026-12605/): Server-side request forgery in Eclipse GlassFish (critical 9.6)
- [CVE-2026-2586](https://insights.sbomify.com/CVE-2026-2586/): GlassFish's Administration Console is Vulnerable to RCE (critical 9.1)
- [CVE-2024-9408](https://insights.sbomify.com/CVE-2024-9408/): Eclipse GlassFish is vulnerable to Server Side Request Forgery attacks through specific endpoints (high 8.9)
- [CVE-2024-9329](https://insights.sbomify.com/CVE-2024-9329/): Glassfish redirect to untrusted site (medium 6.9)
- [CVE-2023-5763](https://insights.sbomify.com/CVE-2023-5763/): Glassfish remote code execution (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2587 and fix it if it is affected.

What it is: CVE-2026-2587 is a critical code injection vulnerability in Eclipse Glassfish, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-2587 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.glassfish.jsftemplating:jsftemplating (Maven): affected all versions; fixed in 4.2.0
- org.glassfish.jsftemplating:jsftemplating (Maven): affected all versions; fixed in 4.2.0
- org.glassfish.main.admingui:admingui (Maven): affected all versions; fixed in 8.0.2
- org.glassfish.main.admingui:admingui (Maven): affected all versions; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2587/ (Markdown: https://insights.sbomify.com/CVE-2026-2587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2587
- OSV: https://osv.dev/vulnerability/CVE-2026-2587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2587/
Summaries are generated and may contain mistakes; the official description above is the record.
