# CVE-2026-25882: Fiber has a Denial of Service Vulnerability via Route Parameter Overflow

> Remote attackers can crash Fiber web applications by sending requests with excessive route parameters, requiring an upgrade to patched versions.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-mrq8-rjmw-wpq3, GO-2026-4543

## What is CVE-2026-25882?

CVE-2026-25882 is a medium-severity denial of service vulnerability in gofiber fiber, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber is an Express inspired web framework written in Go. A denial of service vulnerability exists in Fiber v2 and v3 that allows remote attackers to crash the application by sending requests to routes with more than 30 parameters. The vulnerability results from missing validation during route registration combined with an unbounded array write during request matching. Version 2.52.12 patches the issue in the v2 branch and 3.1.0 patches the issue in the v3 branch.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-25882?

6 open source packages ship an affected version, including github.com/gofiber/fiber/v2 and github.com/gofiber/fiber/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.12 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.12 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.12 |
| `github.com/gofiber/fiber/v3` | Go | All versions | 3.1.0 |
| `github.com/gofiber/fiber/v3` | Go | All versions | 3.1.0 |
| `github.com/gofiber/fiber/v3` | Go | All versions | 3.1.0 |

Products: Gofiber Fiber.

## How do I fix CVE-2026-25882?

Upgrade github.com/gofiber/fiber/v2 to 2.52.12 or later.

## Is CVE-2026-25882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25882 exists.

## Other vulnerabilities in gofiber fiber

- [CVE-2024-38513](https://insights.sbomify.com/CVE-2024-38513/): Fiber Session Middleware Token Injection Vulnerability (critical 10.0)
- [CVE-2023-45128](https://insights.sbomify.com/CVE-2023-45128/): CSRF Token Reuse Vulnerability in fiber (critical 10.0)
- [CVE-2024-25124](https://insights.sbomify.com/CVE-2024-25124/): Fiber has Insecure CORS Configuration, Allowing Wildcard Origin with Credentials (critical 9.4)
- [CVE-2025-66630](https://insights.sbomify.com/CVE-2025-66630/): Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure (critical 9.2)
- [CVE-2025-54801](https://insights.sbomify.com/CVE-2025-54801/): Fiber Susceptible to Crash via `BodyParser` Due to Unvalidated Large Slice Index in Decoder (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25882 and fix it if it is affected.

What it is: CVE-2026-25882 is a medium-severity denial of service vulnerability in gofiber fiber, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25882 exists.

Affected packages and fixed versions:
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.12
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.12
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.12
- github.com/gofiber/fiber/v3 (Go): affected all versions; fixed in 3.1.0
- github.com/gofiber/fiber/v3 (Go): affected all versions; fixed in 3.1.0
- github.com/gofiber/fiber/v3 (Go): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25882/ (Markdown: https://insights.sbomify.com/CVE-2026-25882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25882
- OSV: https://osv.dev/vulnerability/CVE-2026-25882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25882/
Summaries are generated and may contain mistakes; the official description above is the record.
