# CVE-2026-25888: Chartbrew: Remote Code Execution (RCE) via Vulnerable API


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 6 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-875w-45c2-gxq8

## What is CVE-2026-25888?

CVE-2026-25888 is a high-severity vulnerability in chartbrew, published on 6 Mar 2026. 

### Official description

Chartbrew is an open-source web application that can connect directly to databases and APIs and use the data to create charts. Prior to version 4.8.1, there is a remote code execution vulnerability via a vulnerable API. This issue has been patched in version 4.8.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-25888?

It affects 1 product.


Products: Depomo Chartbrew.

## How do I fix CVE-2026-25888?

No fix has been published for CVE-2026-25888 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25888 being exploited?

There is no known exploitation of CVE-2026-25888 in the wild and no public exploit code.

## Other vulnerabilities in chartbrew

- [CVE-2026-27005](https://insights.sbomify.com/CVE-2026-27005/): Chartbrew: SQL injection in date-type variable handling (applyMysqlOrPostgresVariables) (high 8.8)
- [CVE-2026-27603](https://insights.sbomify.com/CVE-2026-27603/): Missing authorization in chartbrew (high 8.7)
- [CVE-2026-30232](https://insights.sbomify.com/CVE-2026-30232/): Chartbrew has SSRF in API Data Connection - No IP Validation on User-Provided URLs (high 7.8)
- [CVE-2026-32252](https://insights.sbomify.com/CVE-2026-32252/): Chartbrew Cross-Tenant Template Export and Secret Disclosure in `GET /team/:team_id/template/generate/:project_id` (high 7.7)
- [CVE-2026-25887](https://insights.sbomify.com/CVE-2026-25887/): Chartbrew: Remote Code Execution (RCE) via MongoDB Dataset Query (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25888 and fix it if it is affected.

What it is: CVE-2026-25888 is a high-severity vulnerability in chartbrew, published on 6 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2026-25888 in the wild and no public exploit code.

Affected product: chartbrew. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25888/ (Markdown: https://insights.sbomify.com/CVE-2026-25888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25888
- OSV: https://osv.dev/vulnerability/CVE-2026-25888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25888/
Summaries are generated and may contain mistakes; the official description above is the record.
